aboutsummaryrefslogtreecommitdiff
path: root/math/py-cyipopt
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-04-01 05:32:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-04-01 05:32:21 +0000
commit9881ada7722c53972d7f47dfd9c367af17ac1a6b (patch)
tree63fea195896bf20f72b8782f9fe9a2fc75ccd340 /math/py-cyipopt
parent3e16f8dadf57ff6ab33107f863de5caf6bffec0b (diff)
downloadports-9881ada7722c53972d7f47dfd9c367af17ac1a6b.tar.gz
ports-9881ada7722c53972d7f47dfd9c367af17ac1a6b.zip
New port: math/py-cyipopt: Cython interface for the interior point optimizer IPOPT
Notes
Notes: svn path=/head/; revision=466116
Diffstat (limited to 'math/py-cyipopt')
-rw-r--r--math/py-cyipopt/Makefile31
-rw-r--r--math/py-cyipopt/distinfo3
-rw-r--r--math/py-cyipopt/pkg-descr7
3 files changed, 41 insertions, 0 deletions
diff --git a/math/py-cyipopt/Makefile b/math/py-cyipopt/Makefile
new file mode 100644
index 000000000000..9b556bb3400b
--- /dev/null
+++ b/math/py-cyipopt/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= cyipopt
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.7
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Cython interface for the interior point optimizer IPOPT
+
+LICENSE= EPL
+
+BUILD_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR}
+LIB_DEPENDS= libblas.so:math/blas \
+ libcoinmetis.so:math/ipopt \
+ liblapack.so:math/lapack
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${FLAVOR}
+
+USES= fortran python pkgconfig # fortran because ipopt's pkg-config returns gcc libs
+USE_GITHUB= yes
+GH_ACCOUNT= matthias-k
+USE_PYTHON= distutils cython autoplist
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME}.so
+
+.include <bsd.port.mk>
diff --git a/math/py-cyipopt/distinfo b/math/py-cyipopt/distinfo
new file mode 100644
index 000000000000..b844d5b50633
--- /dev/null
+++ b/math/py-cyipopt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522559375
+SHA256 (matthias-k-cyipopt-v0.1.7_GH0.tar.gz) = e62d4265743078c60f0af1426218310a9fbc1b6d0d0e60879e172d569dd3343d
+SIZE (matthias-k-cyipopt-v0.1.7_GH0.tar.gz) = 40782
diff --git a/math/py-cyipopt/pkg-descr b/math/py-cyipopt/pkg-descr
new file mode 100644
index 000000000000..c1ae618f6188
--- /dev/null
+++ b/math/py-cyipopt/pkg-descr
@@ -0,0 +1,7 @@
+Ipopt (Interior Point OPTimizer, pronounced eye-pea-Opt) is a software package
+for large-scale nonlinear optimization.
+
+cyipopt is a python wrapper around Ipopt. It enables using Ipopt from the
+comfort of the great Python scripting language.
+
+WWW: https://github.com/matthias-k/cyipopt