aboutsummaryrefslogtreecommitdiff
path: root/math/py-cypari2
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2020-05-15 21:05:52 +0000
committerThierry Thomas <thierry@FreeBSD.org>2020-05-15 21:05:52 +0000
commit8541ea4c32e930f32384f266fce15c79b346f237 (patch)
treebd812c4b6304c220c295e2bd5ae8b24187a3ae55 /math/py-cypari2
parent688f3b4e5e5fbf8e595bf26b1dc94d36108b12b9 (diff)
downloadports-8541ea4c32e930f32384f266fce15c79b346f237.tar.gz
ports-8541ea4c32e930f32384f266fce15c79b346f237.zip
Adding cypari2, a Python interface to the number theory library PARI/GP.
To be used by SageMath.
Notes
Notes: svn path=/head/; revision=535335
Diffstat (limited to 'math/py-cypari2')
-rw-r--r--math/py-cypari2/Makefile42
-rw-r--r--math/py-cypari2/distinfo3
-rw-r--r--math/py-cypari2/pkg-descr3
-rw-r--r--math/py-cypari2/pkg-plist22
4 files changed, 70 insertions, 0 deletions
diff --git a/math/py-cypari2/Makefile b/math/py-cypari2/Makefile
new file mode 100644
index 000000000000..20e199c7a3fc
--- /dev/null
+++ b/math/py-cypari2/Makefile
@@ -0,0 +1,42 @@
+# Created by: thierry@pompo.net
+# $FreeBSD$
+
+PORTNAME= cypari2
+DISTVERSION= 2.1.1
+CATEGORIES= math python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Python interface to the number theory library PARI/GP
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cysignals>0:devel/py-cysignals@${PY_FLAVOR}
+LIB_DEPENDS= libgmp.so:math/gmp \
+ libpari.so:math/pari
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cysignals>0:devel/py-cysignals@${PY_FLAVOR}
+
+USE_GITHUB= yes
+GH_ACCOUNT= sagemath
+
+USES= perl5 python:3.6+
+USE_PERL5= build
+USE_PYTHON= cython distutils
+
+OPTIONS_DEFINE= DOCS
+DOCS_BUILD_DEPENDS= ${PY_SPHINX}
+DOCS_USES= gmake
+PORTDOCS= *
+
+pre-configure-DOCS-on:
+ ${REINPLACE_CMD} -e 's|python -m|${PYTHON_CMD} -m|' \
+ ${WRKSRC}/docs/Makefile
+
+do-build-DOCS-on:
+ (cd ${WRKSRC}/docs && ${GMAKE} html)
+
+post-build-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${CP} -R ${WRKSRC}/docs/build/html/* ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/math/py-cypari2/distinfo b/math/py-cypari2/distinfo
new file mode 100644
index 000000000000..b25a6b77a933
--- /dev/null
+++ b/math/py-cypari2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1589574266
+SHA256 (sagemath-cypari2-2.1.1_GH0.tar.gz) = 8b707cba6f5ed249105348d3e29ce55c12c7ed5556ff6e0ae03f7aa792321e10
+SIZE (sagemath-cypari2-2.1.1_GH0.tar.gz) = 123990
diff --git a/math/py-cypari2/pkg-descr b/math/py-cypari2/pkg-descr
new file mode 100644
index 000000000000..3619d2c612eb
--- /dev/null
+++ b/math/py-cypari2/pkg-descr
@@ -0,0 +1,3 @@
+A Python interface to the number theory library PARI/GP.
+
+WWW: https://github.com/sagemath/cypari2
diff --git a/math/py-cypari2/pkg-plist b/math/py-cypari2/pkg-plist
new file mode 100644
index 000000000000..5105b3786ad1
--- /dev/null
+++ b/math/py-cypari2/pkg-plist
@@ -0,0 +1,22 @@
+%%PYTHON_SITELIBDIR%%/cypari2/__init__.py
+%%PYTHON_SITELIBDIR%%/cypari2/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/cypari2/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/cypari2/auto_paridecl.pxd
+%%PYTHON_SITELIBDIR%%/cypari2/closure.pxd
+%%PYTHON_SITELIBDIR%%/cypari2/closure.so
+%%PYTHON_SITELIBDIR%%/cypari2/convert.pxd
+%%PYTHON_SITELIBDIR%%/cypari2/convert.so
+%%PYTHON_SITELIBDIR%%/cypari2/cypari.h
+%%PYTHON_SITELIBDIR%%/cypari2/gen.pxd
+%%PYTHON_SITELIBDIR%%/cypari2/gen.so
+%%PYTHON_SITELIBDIR%%/cypari2/handle_error.pxd
+%%PYTHON_SITELIBDIR%%/cypari2/handle_error.so
+%%PYTHON_SITELIBDIR%%/cypari2/pari_instance.pxd
+%%PYTHON_SITELIBDIR%%/cypari2/pari_instance.so
+%%PYTHON_SITELIBDIR%%/cypari2/paridecl.pxd
+%%PYTHON_SITELIBDIR%%/cypari2/paripriv.pxd
+%%PYTHON_SITELIBDIR%%/cypari2/stack.pxd
+%%PYTHON_SITELIBDIR%%/cypari2/stack.so
+%%PYTHON_SITELIBDIR%%/cypari2/string_utils.pxd
+%%PYTHON_SITELIBDIR%%/cypari2/string_utils.so
+%%PYTHON_SITELIBDIR%%/cypari2/types.pxd