aboutsummaryrefslogtreecommitdiff
path: root/math/py-fastcluster
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-02-25 05:33:33 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-02-25 05:33:33 +0000
commite94de26b975748056fe6044c6fd86d68722be6a0 (patch)
tree01a8cf8eb427f8320505ef89e743ec4eb6192a86 /math/py-fastcluster
parent4dc7ffa1f5d12a789ebaf8a3c9d90c8e5fccdf65 (diff)
downloadports-e94de26b975748056fe6044c6fd86d68722be6a0.tar.gz
ports-e94de26b975748056fe6044c6fd86d68722be6a0.zip
Update to 1.1.24
- Update COMMENT - Add LICENSE_FILE - Add missing OPTIONS_DEFINE=DOCS - Strip shared library - Convert to options target helper - Add PyPI and GitHub repository to WWW - Take maintainership Changes: https://github.com/dmuellner/fastcluster https://github.com/dmuellner/fastcluster/blob/master/NEWS.txt
Notes
Notes: svn path=/head/; revision=462923
Diffstat (limited to 'math/py-fastcluster')
-rw-r--r--math/py-fastcluster/Makefile25
-rw-r--r--math/py-fastcluster/distinfo6
-rw-r--r--math/py-fastcluster/pkg-descr16
3 files changed, 26 insertions, 21 deletions
diff --git a/math/py-fastcluster/Makefile b/math/py-fastcluster/Makefile
index 7e00d08b7b9d..f7327aaa8fcb 100644
--- a/math/py-fastcluster/Makefile
+++ b/math/py-fastcluster/Makefile
@@ -2,30 +2,33 @@
# $FreeBSD$
PORTNAME= fastcluster
-PORTVERSION= 1.1.23
+PORTVERSION= 1.1.24
CATEGORIES= math python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Python functions for hierarchical clustering
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Fast hierarchical clustering routines for R and Python
LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING.txt
BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${FLAVOR}
-
-PORTDOCS= CITATION.txt \
- INSTALL.txt \
- NEWS.txt \
- README.txt
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0:science/py-scipy@${FLAVOR}
USES= python
-USE_PYTHON= distutils autoplist concurrent
+USE_PYTHON= autoplist concurrent distutils
+
+PORTDOCS= CITATION.txt INSTALL.txt NEWS.txt README.txt
+
+OPTIONS_DEFINE= DOCS
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/_fastcluster.so
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/math/py-fastcluster/distinfo b/math/py-fastcluster/distinfo
index 78dca96c6184..6cb1b490a9fb 100644
--- a/math/py-fastcluster/distinfo
+++ b/math/py-fastcluster/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1495026276
-SHA256 (fastcluster-1.1.23.tar.gz) = dfcd192d4cd53cd0db27f9d86dc3c49d3a15e6114ff875428c367b8bd679e318
-SIZE (fastcluster-1.1.23.tar.gz) = 163512
+TIMESTAMP = 1519504273
+SHA256 (fastcluster-1.1.24.tar.gz) = a5d1922b1db6f4c3012416e7dc14de2984b9335a48c895e1698afd5c718312b0
+SIZE (fastcluster-1.1.24.tar.gz) = 166081
diff --git a/math/py-fastcluster/pkg-descr b/math/py-fastcluster/pkg-descr
index 69815a4b6480..7af1b6ba631c 100644
--- a/math/py-fastcluster/pkg-descr
+++ b/math/py-fastcluster/pkg-descr
@@ -1,14 +1,16 @@
-Fastcluster provides Python functions for hierarchical clustering. It generates
+This library provides Python functions for hierarchical clustering. It generates
hierarchical clusters from distance matrices or from vector data.
-Part of this module is intended to replace the functions
- linkage, single, complete, average, weighted, centroid, median, ward
-in the module scipy.cluster.hierarchy with the same functionality but much
-faster algorithms. Moreover, the function 'linkage_vector' provides
-memory-efficient clustering for vector data.
+Part of this module is intended to replace the functions (linkage, single,
+complete, average, weighted, centroid, median, ward) in the module
+scipy.cluster.hierarchy with the same functionality but much faster algorithms.
+Moreover, the function linkage_vector provides memory-efficient clustering for
+vector data.
The interface is very similar to MATLAB's Statistics Toolbox API to make code
-easier to port from MATLAB to Python/Numpy. The core implementation of this
+easier to port from MATLAB to Python/NumPy. The core implementation of this
library is in C++ for efficiency.
WWW: http://danifold.net/fastcluster.html
+WWW: https://pypi.python.org/pypi/fastcluster
+WWW: https://github.com/dmuellner/fastcluster