aboutsummaryrefslogtreecommitdiff
path: root/math/py-fastdtw
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-09-21 08:25:54 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-09-21 08:25:54 +0000
commit58d61c992cae4e9b42f27cd15c993c8d3570d87f (patch)
treef45b2fb9dd7a3ce67a6adcefa1cb4f7ead09b53b /math/py-fastdtw
parent797a45a4f76caf1a4040e52ede29a457045d912c (diff)
downloadports-58d61c992cae4e9b42f27cd15c993c8d3570d87f.tar.gz
ports-58d61c992cae4e9b42f27cd15c993c8d3570d87f.zip
New port: math/py-fastdtw: Dynamic Time Warping (DTW) algorithm with an O(N) complexity
Notes
Notes: svn path=/head/; revision=480238
Diffstat (limited to 'math/py-fastdtw')
-rw-r--r--math/py-fastdtw/Makefile27
-rw-r--r--math/py-fastdtw/distinfo3
-rw-r--r--math/py-fastdtw/pkg-descr7
3 files changed, 37 insertions, 0 deletions
diff --git a/math/py-fastdtw/Makefile b/math/py-fastdtw/Makefile
new file mode 100644
index 000000000000..aafafaf66744
--- /dev/null
+++ b/math/py-fastdtw/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= fastdtw
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.3.2
+CATEGORIES= math python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Dynamic Time Warping (DTW) algorithm with an O(N) complexity
+
+LICENSE= GPLv3
+xLICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${PY_FLAVOR}
+RUN_DEPENDS= ${PYNUMPY}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python
+USE_GITHUB= yes # tests are only on github
+GH_ACCOUNT= slaypni
+USE_PYTHON= distutils cython autoplist
+
+do-test: # tests fail: https://github.com/slaypni/fastdtw/issues/23
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest
+
+.include <bsd.port.mk>
diff --git a/math/py-fastdtw/distinfo b/math/py-fastdtw/distinfo
new file mode 100644
index 000000000000..8953f44646b6
--- /dev/null
+++ b/math/py-fastdtw/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1537517761
+SHA256 (slaypni-fastdtw-v0.3.2_GH0.tar.gz) = 3c0efb7acb05892ebe086f26ec844c0ff60c4ec12c093c6d5217f30537df44cb
+SIZE (slaypni-fastdtw-v0.3.2_GH0.tar.gz) = 122086
diff --git a/math/py-fastdtw/pkg-descr b/math/py-fastdtw/pkg-descr
new file mode 100644
index 000000000000..124d00327de4
--- /dev/null
+++ b/math/py-fastdtw/pkg-descr
@@ -0,0 +1,7 @@
+Python implementation of FastDTW [1], which is an approximate Dynamic Time
+Warping (DTW) algorithm that provides optimal or near-optimal alignments
+with an O(N) time and memory complexity.
+
+[1] http://cs.fit.edu/~pkc/papers/tdm04.pdf
+
+WWW: https://github.com/slaypni/fastdtw