aboutsummaryrefslogtreecommitdiff
path: root/math/py-ffc/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-05-23 17:56:55 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-05-23 17:56:55 +0000
commit939653a68543fd90f6c7e456fbde4e5d12db7c5f (patch)
tree91b6b5b6ba186e38ffe5feb20acc4953710288b9 /math/py-ffc/Makefile
parent836bbdb2236168f2c84ffbdf9112e7a7055c7c3f (diff)
Notes
Diffstat (limited to 'math/py-ffc/Makefile')
-rw-r--r--math/py-ffc/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/math/py-ffc/Makefile b/math/py-ffc/Makefile
index a24a50c9cd0a..686c2142e068 100644
--- a/math/py-ffc/Makefile
+++ b/math/py-ffc/Makefile
@@ -1,29 +1,30 @@
-# New ports collection makefile for: py-ffc
-# Date created: 12 April 2012
-# Whom: Jason Bacon <jwbacon@tds.net>
-#
+# Created by: Jason Bacon <jwbacon@tds.net>
# $FreeBSD$
-#
PORTNAME= ffc
-PORTVERSION= 1.0.0
+PORTVERSION= ${MMVERSION}.0
CATEGORIES= math python
-MASTER_SITES= https://launchpad.net/${PORTNAME}/1.0.x/${PORTVERSION}/+download/
+MASTER_SITES= https://launchpad.net/${PORTNAME}/${MMVERSION}.x/${PORTVERSION}/+download/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= jwbacon@tds.net
COMMENT= C++ code generator for multilinear forms
+LICENSE= LGPL3
+
USE_PYTHON= -2.7
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= FFC
-FETCH_ARGS= -Fpr
+FETCH_ARGS= -F
MAN1= ffc.1
MANCOMPRESSED= yes
+MMVERSION= 1.2
+
post-patch:
- @${REINPLACE_CMD} -e 's|"usr")|"usr", "local")|g' ${WRKSRC}/test/regression/test.py
+ ${REINPLACE_CMD} -i '' -e 's|os.path.join(os.path.sep, "usr")|os.path.normpath("${PREFIX}")|' \
+ ${WRKSRC}/test/regression/test.py
.include <bsd.port.mk>