aboutsummaryrefslogtreecommitdiff
path: root/math/py-gau2grid
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-20 18:04:42 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-20 18:04:42 +0000
commit8bd4af7af45e21d305d112025e25419e9ec6feb4 (patch)
tree4cdf4c599dfc1763f3c6c4a962323a88582f7bda /math/py-gau2grid
parentdcc074b91fda6c1e4e023d9cc6d7590dd33de209 (diff)
downloadports-8bd4af7af45e21d305d112025e25419e9ec6feb4.tar.gz
ports-8bd4af7af45e21d305d112025e25419e9ec6feb4.zip
math/py-gau2grid: Undelete because it isn't broken
It isn't broken: it has a bug that it breaks on architectures other than amd64.
Notes
Notes: svn path=/head/; revision=482609
Diffstat (limited to 'math/py-gau2grid')
-rw-r--r--math/py-gau2grid/Makefile31
-rw-r--r--math/py-gau2grid/distinfo3
-rw-r--r--math/py-gau2grid/pkg-descr7
3 files changed, 41 insertions, 0 deletions
diff --git a/math/py-gau2grid/Makefile b/math/py-gau2grid/Makefile
new file mode 100644
index 000000000000..93eb4db78633
--- /dev/null
+++ b/math/py-gau2grid/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= gau2grid
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.2.0
+CATEGORIES= math python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Fast computation of a gaussian and its derivative on a grid
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS_REASON= BUG: ValueError: descr is not a valid dtype descriptor: '<f16' (see https://github.com/dgasmith/gau2grid/issues/25)
+
+BUILD_DEPENDS= ${PYNUMPY} \
+ cmake:devel/cmake
+RUN_DEPENDS= ${PYNUMPY}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= dgasmith
+USE_PYTHON= distutils autoplist
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest
+
+.include <bsd.port.mk>
diff --git a/math/py-gau2grid/distinfo b/math/py-gau2grid/distinfo
new file mode 100644
index 000000000000..189a7918ed6e
--- /dev/null
+++ b/math/py-gau2grid/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1538885352
+SHA256 (dgasmith-gau2grid-v1.2.0_GH0.tar.gz) = 5c0312256c794d17c806bafa4a755489d21d3985e44a4429e865b51e67666b9c
+SIZE (dgasmith-gau2grid-v1.2.0_GH0.tar.gz) = 124928
diff --git a/math/py-gau2grid/pkg-descr b/math/py-gau2grid/pkg-descr
new file mode 100644
index 000000000000..2a8fcb58b544
--- /dev/null
+++ b/math/py-gau2grid/pkg-descr
@@ -0,0 +1,7 @@
+gau2grid is a python-generated C library for vectorized computation of grid to
+gaussian collocation matrices
+
+The core of gau2grid is generating the collocation matrices between a real space
+grid and a gaussian basis set expanded to a given angular momenta.
+
+WWW: https://github.com/dgasmith/gau2grid