aboutsummaryrefslogtreecommitdiff
path: root/math/py-gmpy
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-07-18 13:15:24 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-07-18 13:15:24 +0000
commitb16eff54df864356a56b96ae96ffe2b5ddc37d1a (patch)
treea97e535ce4b5c78b93b388526af5b8e51ca8deb6 /math/py-gmpy
parent5b8e3545da356a385d4760f03d2054c215020b7a (diff)
downloadports-b16eff54df864356a56b96ae96ffe2b5ddc37d1a.tar.gz
ports-b16eff54df864356a56b96ae96ffe2b5ddc37d1a.zip
Readded in math/
A C-coded Python extension module that wraps the GMP library to provide to Python code fast multiprecision arithmetic (integer, rational, and float), random number generation, advanced number-theoretical functions, and more. WWW: http://code.google.com/p/gmpy/
Notes
Notes: svn path=/head/; revision=217040
Diffstat (limited to 'math/py-gmpy')
-rw-r--r--math/py-gmpy/Makefile25
-rw-r--r--math/py-gmpy/distinfo3
-rw-r--r--math/py-gmpy/pkg-descr6
3 files changed, 34 insertions, 0 deletions
diff --git a/math/py-gmpy/Makefile b/math/py-gmpy/Makefile
new file mode 100644
index 000000000000..83e322f26eca
--- /dev/null
+++ b/math/py-gmpy/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: py-gmpy
+# Date created: 09 July 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmpy
+PORTVERSION= 1.03
+CATEGORIES= math python
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Read Write And Modify MARC Bibliographic Data
+
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+
+USE_ZIP= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/gmpy.so
+
+.include <bsd.port.mk>
diff --git a/math/py-gmpy/distinfo b/math/py-gmpy/distinfo
new file mode 100644
index 000000000000..73a82f107117
--- /dev/null
+++ b/math/py-gmpy/distinfo
@@ -0,0 +1,3 @@
+MD5 (gmpy-1.03.zip) = 7e723068ecd7078b32f344c747586592
+SHA256 (gmpy-1.03.zip) = dfb02ffd2356aee74c756ac8e235bcaa89e3e0e5199f9fd4b9dfda54c7ff71c7
+SIZE (gmpy-1.03.zip) = 86711
diff --git a/math/py-gmpy/pkg-descr b/math/py-gmpy/pkg-descr
new file mode 100644
index 000000000000..40dbbb94e7dd
--- /dev/null
+++ b/math/py-gmpy/pkg-descr
@@ -0,0 +1,6 @@
+A C-coded Python extension module that wraps the GMP library to provide
+to Python code fast multiprecision arithmetic (integer, rational, and
+float), random number generation, advanced number-theoretical functions,
+and more.
+
+WWW: http://code.google.com/p/gmpy/