aboutsummaryrefslogtreecommitdiff
path: root/math/py-graphillion
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-03-03 10:54:53 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-03-03 10:54:53 +0000
commitb634f9269baa1b6396fff869019f23d63e83c523 (patch)
tree1fff69eb42fb7d15d2183d51781fa546d817ffb6 /math/py-graphillion
parent196e67a9e6b0375e43aeb55de1664f823bfecd05 (diff)
downloadports-b634f9269baa1b6396fff869019f23d63e83c523.tar.gz
ports-b634f9269baa1b6396fff869019f23d63e83c523.zip
Notes
Diffstat (limited to 'math/py-graphillion')
-rw-r--r--math/py-graphillion/Makefile12
-rw-r--r--math/py-graphillion/distinfo4
-rw-r--r--math/py-graphillion/files/patch-setup.py8
3 files changed, 8 insertions, 16 deletions
diff --git a/math/py-graphillion/Makefile b/math/py-graphillion/Makefile
index e8b8dd4c3e30..a9118df96039 100644
--- a/math/py-graphillion/Makefile
+++ b/math/py-graphillion/Makefile
@@ -2,24 +2,24 @@
# $FreeBSD$
PORTNAME= graphillion
-PORTVERSION= 0.98
-DISTVERSIONPREFIX= v
+PORTVERSION= 0.99
CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:S/g/G/}-${PORTVERSION}
MAINTAINER= koobs@FreeBSD.org
COMMENT= Fast, lightweight graphset operation library in Python
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
USES= python
-USE_GITHUB= yes
USE_PYTHON= distutils autoplist
-GH_ACCOUNT= takemaru
-
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/_graphillion.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/_graphillion.so
+
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
diff --git a/math/py-graphillion/distinfo b/math/py-graphillion/distinfo
index 91e65a0ff6c9..c88c4b42ac6b 100644
--- a/math/py-graphillion/distinfo
+++ b/math/py-graphillion/distinfo
@@ -1,2 +1,2 @@
-SHA256 (takemaru-graphillion-v0.98_GH0.tar.gz) = f9e7995352d7da510f47f3c322753486b1b2482aaf673359d906b0c32e0fcfb4
-SIZE (takemaru-graphillion-v0.98_GH0.tar.gz) = 1588861
+SHA256 (Graphillion-0.99.tar.gz) = e635f8c12a94abd4fe13bd99e33a326a661ac7d13198b6fbb11060c117b19ab0
+SIZE (Graphillion-0.99.tar.gz) = 1041596
diff --git a/math/py-graphillion/files/patch-setup.py b/math/py-graphillion/files/patch-setup.py
deleted file mode 100644
index b6eeff4fba95..000000000000
--- a/math/py-graphillion/files/patch-setup.py
+++ /dev/null
@@ -1,8 +0,0 @@
---- ./setup.py.orig 2013-06-21 19:44:04.348822813 +1000
-+++ ./setup.py 2013-06-21 19:44:14.872371187 +1000
-@@ -51,4 +51,5 @@
- ),
- ],
- test_suite='graphillion.test',
-+ zip_safe=False,
- )