aboutsummaryrefslogtreecommitdiff
path: root/math/py-iohexperimenter
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-30 12:25:01 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-30 12:25:01 +0000
commit2b3acf62a460931d6c772854892061ae337bccbc (patch)
tree0cbae9f85267d9ffbaef9dfa2dfc6541f87601a6 /math/py-iohexperimenter
parentd93a60ad470e695984fb7fcd15caa04aba81d117 (diff)
downloadports-2b3acf62a460931d6c772854892061ae337bccbc.tar.gz
ports-2b3acf62a460931d6c772854892061ae337bccbc.zip
Update to 0.2.9
Notes
Notes: svn path=/head/; revision=563336
Diffstat (limited to 'math/py-iohexperimenter')
-rw-r--r--math/py-iohexperimenter/Makefile10
-rw-r--r--math/py-iohexperimenter/distinfo6
-rw-r--r--math/py-iohexperimenter/files/patch-setup.py11
3 files changed, 22 insertions, 5 deletions
diff --git a/math/py-iohexperimenter/Makefile b/math/py-iohexperimenter/Makefile
index 0d4506283c54..f2e4f0ab9184 100644
--- a/math/py-iohexperimenter/Makefile
+++ b/math/py-iohexperimenter/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= iohexperimenter
-PORTVERSION= 0.2.8.7
+PORTVERSION= 0.2.9
CATEGORIES= math python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,7 +14,7 @@ COMMENT= Experimenter for Iterative Optimization Heuristic
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYNUMPY}
+xRUN_DEPENDS= ${PYNUMPY}
USES= compiler:c++14-lang dos2unix python:3.6+
USE_PYTHON= autoplist concurrent distutils
@@ -23,4 +23,10 @@ USE_CXXSTD= c++14
WRKSRC= ${WRKDIR}/IOHexperimenter-${PORTVERSION}
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${WRKSRC}/setup.py
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/IOHexperimenter/_IOHprofiler*.so
+
.include <bsd.port.mk>
diff --git a/math/py-iohexperimenter/distinfo b/math/py-iohexperimenter/distinfo
index dcd52838a611..2cd70668006b 100644
--- a/math/py-iohexperimenter/distinfo
+++ b/math/py-iohexperimenter/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1608366162
-SHA256 (IOHexperimenter-0.2.8.7.tar.gz) = 7a22e56b2626bdf30d637677413670a9211ca72a78cf6cf76b57a63f8b288e77
-SIZE (IOHexperimenter-0.2.8.7.tar.gz) = 245011
+TIMESTAMP = 1611856576
+SHA256 (IOHexperimenter-0.2.9.tar.gz) = 81e0dcdc6b966ebdb53f990d73b8cd024fe13f75c871189b6f7364f93345b6b5
+SIZE (IOHexperimenter-0.2.9.tar.gz) = 245074
diff --git a/math/py-iohexperimenter/files/patch-setup.py b/math/py-iohexperimenter/files/patch-setup.py
new file mode 100644
index 000000000000..b9f8c5288b66
--- /dev/null
+++ b/math/py-iohexperimenter/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2021-01-26 09:46:22 UTC
++++ setup.py
+@@ -30,7 +30,7 @@ iohprofiler = Extension('IOHexperimenter._IOHprofiler'
+ extra_compile_args=extra_compile_args
+ )
+
+-__version__ = "auto"
++__version__ = "%%PORTVERSION%%"
+ gh_ref = os.environ.get("GITHUB_REF")
+ if gh_ref:
+ *_, tag = gh_ref.split("/")