aboutsummaryrefslogtreecommitdiff
path: root/math/py-libpoly
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-07-21 09:00:06 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-07-21 09:00:06 +0000
commit99daed97c6d52e64ff6cac0d74f401951d610738 (patch)
tree43ecddfee4c843ec78e9bd75cb0c7598eae944c9 /math/py-libpoly
parentc7b44c1d8a4e2997fcbce75e6bf4585896ce63e6 (diff)
downloadports-99daed97c6d52e64ff6cac0d74f401951d610738.tar.gz
ports-99daed97c6d52e64ff6cac0d74f401951d610738.zip
New port: math/py-libpoly: Python binding for libpoly
Notes
Notes: svn path=/head/; revision=475056
Diffstat (limited to 'math/py-libpoly')
-rw-r--r--math/py-libpoly/Makefile35
-rw-r--r--math/py-libpoly/distinfo3
-rw-r--r--math/py-libpoly/files/patch-CMakeLists.txt19
-rw-r--r--math/py-libpoly/pkg-descr3
4 files changed, 60 insertions, 0 deletions
diff --git a/math/py-libpoly/Makefile b/math/py-libpoly/Makefile
new file mode 100644
index 000000000000..537d19a1d277
--- /dev/null
+++ b/math/py-libpoly/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= libpoly
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.7
+CATEGORIES= math
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python binding for libpoly
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENCE
+
+LIB_DEPENDS= libpoly.so:math/libpoly
+
+USES= cmake:outsource localbase:ldflags python:2.7
+USE_GITHUB= yes
+GH_ACCOUNT= SRI-CSL
+USE_LDCONFIG= yes
+USE_PYTHON= distutils autoplist
+
+CFLAGS+= -I${WRKSRC}/include
+LDFLAGS+= -lpoly
+
+BUILD_WRKSRC= ${WRKSRC}/python
+INSTALL_WRKSRC= ${WRKSRC}/python
+
+do-build:
+ @cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYDISTUTILS_SETUP} ${PYDISTUTILS_BUILD_TARGET} ${PYDISTUTILS_BUILDARGS}
+
+do-install:
+ @cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYDISTUTILS_SETUP} ${PYDISTUTILS_INSTALL_TARGET} ${PYDISTUTILS_INSTALLARGS}
+
+.include <bsd.port.mk>
diff --git a/math/py-libpoly/distinfo b/math/py-libpoly/distinfo
new file mode 100644
index 000000000000..cd92de46a234
--- /dev/null
+++ b/math/py-libpoly/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532161301
+SHA256 (SRI-CSL-libpoly-v0.1.7_GH0.tar.gz) = 71d08cc1e97219bde8a0af60dd436ce4266dc3f19ff3a2cabc640bd14f4d8f4d
+SIZE (SRI-CSL-libpoly-v0.1.7_GH0.tar.gz) = 491593
diff --git a/math/py-libpoly/files/patch-CMakeLists.txt b/math/py-libpoly/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..7f5bb64a65d0
--- /dev/null
+++ b/math/py-libpoly/files/patch-CMakeLists.txt
@@ -0,0 +1,19 @@
+--- CMakeLists.txt.orig 2018-07-21 08:36:33 UTC
++++ CMakeLists.txt
+@@ -50,7 +50,7 @@ if(HAVE_OPEN_MEMSTREAM)
+ endif()
+
+ # Configure the library source
+-add_subdirectory(src)
++#add_subdirectory(src)
+
+ # Configure the headers
+ add_subdirectory(include)
+@@ -61,6 +61,6 @@ if(LIBPOLY_BUILD_PYTHON_API)
+ add_subdirectory(python)
+
+ # Configure the tests
+- add_subdirectory(test)
++ #add_subdirectory(test)
+
+ endif()
diff --git a/math/py-libpoly/pkg-descr b/math/py-libpoly/pkg-descr
new file mode 100644
index 000000000000..032b22a0f480
--- /dev/null
+++ b/math/py-libpoly/pkg-descr
@@ -0,0 +1,3 @@
+The python binding for libpoly, the C library for manipulating polynomials.
+
+WWW: https://github.com/SRI-CSL/libpoly