aboutsummaryrefslogtreecommitdiff
path: root/math/py-numarray/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-10-29 09:04:18 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-10-29 09:04:18 +0000
commitdb5f7b6cf1398ed5620a303804068469c49673fc (patch)
treee6440b94cb8fe0eb0f4ce478471123fc2a854b56 /math/py-numarray/Makefile
parent1bc4c308f8d68fb4f9924223feab8e52118f9bf2 (diff)
Notes
Diffstat (limited to 'math/py-numarray/Makefile')
-rw-r--r--math/py-numarray/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/math/py-numarray/Makefile b/math/py-numarray/Makefile
index 7279417b74a0..608241fac022 100644
--- a/math/py-numarray/Makefile
+++ b/math/py-numarray/Makefile
@@ -27,10 +27,15 @@ post-configure:
${PYTHON_CMD} Include/numarray/genapis.py
post-install:
- ${FIND} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/numarray -name "*.so" -exec \
+ @${FIND} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/numarray -name "*.so" -exec \
${STRIP_CMD} {} \;
- @${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${EXAMPLESDIR}
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
@${TAR} -C ${WRKSRC}/Doc -cf- .|${TAR} -C ${STAGEDIR}${DOCSDIR} -xf-
+
+port-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@${TAR} -C ${WRKSRC}/Examples -cf- .|${TAR} -C ${STAGEDIR}${EXAMPLESDIR} -xf-
@${RM} -r ${STAGEDIR}${EXAMPLESDIR}/ufunc/build