aboutsummaryrefslogtreecommitdiff
path: root/math/py-numexpr
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-10-04 19:01:07 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-10-04 19:01:07 +0000
commitb73eff4feb5498d8fd9969e0379fe7e904985058 (patch)
treec85d3d724ca1c7cd77122bf92f0171c72a6bf533 /math/py-numexpr
parent1f047545aef41998fee287fc83ae82c2863318c3 (diff)
downloadports-b73eff4feb5498d8fd9969e0379fe7e904985058.tar.gz
ports-b73eff4feb5498d8fd9969e0379fe7e904985058.zip
Notes
Diffstat (limited to 'math/py-numexpr')
-rw-r--r--math/py-numexpr/Makefile9
-rw-r--r--math/py-numexpr/distinfo4
-rw-r--r--math/py-numexpr/pkg-descr11
3 files changed, 11 insertions, 13 deletions
diff --git a/math/py-numexpr/Makefile b/math/py-numexpr/Makefile
index 5f2cf98ce9ce..61ce5117c61f 100644
--- a/math/py-numexpr/Makefile
+++ b/math/py-numexpr/Makefile
@@ -2,16 +2,16 @@
# $FreeBSD$
PORTNAME= numexpr
-PORTVERSION= 2.4
-DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTVERSION= 2.4.4
CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Fast numerical array expression evaluator for Python and NumPy
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -19,9 +19,6 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PYTHON= autoplist concurrent distutils
USES= python
-GH_ACCOUNT= pydata
-USE_GITHUB= yes
-
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/numexpr/interpreter.so
diff --git a/math/py-numexpr/distinfo b/math/py-numexpr/distinfo
index 0222507d0b0f..554aac63746f 100644
--- a/math/py-numexpr/distinfo
+++ b/math/py-numexpr/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pydata-numexpr-v2.4_GH0.tar.gz) = b3d5f998d1e489c6e3e672d75c2e6b4a871d67fefc6b6154b90795010bee14c0
-SIZE (pydata-numexpr-v2.4_GH0.tar.gz) = 89752
+SHA256 (numexpr-2.4.4.tar.gz) = dfa2fad1af040e93a8022fbe4437f2183bf80e5f64d466381ad589308a73565b
+SIZE (numexpr-2.4.4.tar.gz) = 87133
diff --git a/math/py-numexpr/pkg-descr b/math/py-numexpr/pkg-descr
index d0d54d0e79d0..c2dab9851305 100644
--- a/math/py-numexpr/pkg-descr
+++ b/math/py-numexpr/pkg-descr
@@ -1,16 +1,17 @@
-numexpr - Fast numerical array expression evaluator for Python and NumPy.
+numexpr - Fast numerical array expression evaluator for Python and NumPy.
The numexpr package evaluates multiple-operator array expressions many times
faster than NumPy can. It accepts the expression as a string, analyzes it,
rewrites it more efficiently, and compiles it to faster Python code on the fly.
-It's the next best thing to writing the expression in C and compiling it with
-a specialized just-in-time (JIT) compiler, i.e. it does not require a compiler
-at runtime.
+It's the next best thing to writing the expression in C and compiling it with a
+specialized just-in-time (JIT) compiler, i.e. it does not require a compiler at
+runtime.
Also, numexpr has support for the Intel VML (Vector Math Library) -- integrated
in Intel MKL (Math Kernel Library) --, allowing nice speed-ups when computing
transcendental functions (like trigonometrical, exponentials...) on top of
Intel-compatible platforms. This support also allows to use multiple cores in
-your computations.
+your computations.
+WWW: https://pypi.python.org/pypi/numexpr
WWW: https://github.com/pydata/numexpr