aboutsummaryrefslogtreecommitdiff
path: root/math/py-numpy-groupies
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-03-06 16:34:09 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-03-06 17:09:59 +0000
commitf30cef76c418345083cc705ae5c8a9ceab41bb4d (patch)
treed085331f77d76c821aaeac2e68c18ffde9e02e10 /math/py-numpy-groupies
parentc8b6581835f18a1dae05a4dd9a8b5829fe99b5d7 (diff)
downloadports-f30cef76c418345083cc705ae5c8a9ceab41bb4d.tar.gz
ports-f30cef76c418345083cc705ae5c8a9ceab41bb4d.zip
math/py-numpy-groupies: New port: Optimised tools for group-indexing operations: aggregated sum and more
Diffstat (limited to 'math/py-numpy-groupies')
-rw-r--r--math/py-numpy-groupies/Makefile28
-rw-r--r--math/py-numpy-groupies/distinfo3
-rw-r--r--math/py-numpy-groupies/pkg-descr6
3 files changed, 37 insertions, 0 deletions
diff --git a/math/py-numpy-groupies/Makefile b/math/py-numpy-groupies/Makefile
new file mode 100644
index 000000000000..2de48d4e6869
--- /dev/null
+++ b/math/py-numpy-groupies/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= numpy-groupies
+DISTVERSION= 0.9.14
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:S/-/_/}-${DISTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Optimised tools for group-indexing operations: aggregated sum and more
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pip>0:devel/py-pip@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${PY_FLAVOR}
+TEST_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}numba>0:devel/py-numba@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && pytest
+
+.include <bsd.port.mk>
diff --git a/math/py-numpy-groupies/distinfo b/math/py-numpy-groupies/distinfo
new file mode 100644
index 000000000000..34661bfd3512
--- /dev/null
+++ b/math/py-numpy-groupies/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1646583678
+SHA256 (numpy_groupies-0.9.14.tar.gz) = 01b7aeca60e643db34875c9823ea6775742adafe5bb406bca14367743ef81800
+SIZE (numpy_groupies-0.9.14.tar.gz) = 48868
diff --git a/math/py-numpy-groupies/pkg-descr b/math/py-numpy-groupies/pkg-descr
new file mode 100644
index 000000000000..c09e82b8c7cf
--- /dev/null
+++ b/math/py-numpy-groupies/pkg-descr
@@ -0,0 +1,6 @@
+numpy-groupies is a small library of optimised tools for doing things
+that can roughly be considered "group-indexing operations". The most
+prominent tool is aggregate, which is descibed in detail further down
+the page.
+
+WWW: https://github.com/ml31415/numpy-groupies