aboutsummaryrefslogtreecommitdiff
path: root/math/py-numpy
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-12-19 16:23:48 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-12-19 16:23:48 +0000
commitbf406b4d24664921c84dc872dd7335d549d01ad9 (patch)
tree7d530d9aabea9a037ed02ad61ef394b729dcdf43 /math/py-numpy
parentf3236c06394d3c69e20e56d28c7900758cc80942 (diff)
downloadports-bf406b4d24664921c84dc872dd7335d549d01ad9.tar.gz
ports-bf406b4d24664921c84dc872dd7335d549d01ad9.zip
Enhance USES=uniquefiles to be more generic.
This allows to have more complex renaming schemes. Until now, it could only add a prefix or a suffix, but this was not working at all for man pages, because it would give man/man1/pyfoo.1.gz-2.7 or man/man1/pyfoo-1-2.7.gz. With this change, a man page will be correctly renamed to man/man1/pyfoo-2.7.1.gz. Unfix ports that were already handling man pages. PR: 220214 Submitted by: Fukang Chen (previous patch) Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D13444
Notes
Notes: svn path=/head/; revision=456737
Diffstat (limited to 'math/py-numpy')
-rw-r--r--math/py-numpy/Makefile9
-rw-r--r--math/py-numpy/pkg-plist2
2 files changed, 2 insertions, 9 deletions
diff --git a/math/py-numpy/Makefile b/math/py-numpy/Makefile
index 374ed0fedfdd..d33997ffb19c 100644
--- a/math/py-numpy/Makefile
+++ b/math/py-numpy/Makefile
@@ -46,10 +46,6 @@ TESTS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose@${FLAVOR}
.include <bsd.port.pre.mk>
-.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION}
-PLIST_FILES+= man/man1/f2py.1.gz
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s|%%FC%%|${FC}|" ${WRKSRC}/numpy/distutils/fcompiler/gnu.py
@${CP} ${FILESDIR}/site.cfg ${WRKSRC}/site.cfg
@@ -86,10 +82,7 @@ pre-configure-SUITESPARSE-off:
@${REINPLACE_CMD} -e "s|:%%LOCALBASE%%/include/suitesparse||" ${WRKSRC}/site.cfg
post-install:
- ${INSTALL_MAN} ${WRKSRC}/doc/f2py/f2py.1 ${STAGEDIR}${MANPREFIX}/man/man1/f2py-${PYTHON_VER}.1
-.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION}
- ${LN} -sf f2py-${PYTHON_VER}.1 ${STAGEDIR}${MANPREFIX}/man/man1/f2py.1
-.endif
+ ${INSTALL_MAN} ${WRKSRC}/doc/f2py/f2py.1 ${STAGEDIR}${MANPREFIX}/man/man1/f2py.1
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' | ${XARGS} ${STRIP_CMD}
post-install-DOCS-on:
diff --git a/math/py-numpy/pkg-plist b/math/py-numpy/pkg-plist
index 62b1eb813102..34bee4385f53 100644
--- a/math/py-numpy/pkg-plist
+++ b/math/py-numpy/pkg-plist
@@ -771,4 +771,4 @@ bin/f2py
%%PYTHON_SITELIBDIR%%/numpy/version.py
%%PYTHON_SITELIBDIR%%/numpy/version.pyc
%%PYTHON_SITELIBDIR%%/numpy/version.pyo
-man/man1/f2py-%%PYTHON_VER%%.1.gz
+man/man1/f2py.1.gz