aboutsummaryrefslogtreecommitdiff
path: root/math/py-pandas
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-01-16 15:08:08 +0000
committerSteve Wills <swills@FreeBSD.org>2018-01-16 15:08:08 +0000
commit5ad9370d00c7ff73740ca6bb603b138092da3447 (patch)
tree8f10b9b2f80a9c3a957e91541da14489ff916f36 /math/py-pandas
parent46494d1344d7138fd909efe7656c446b03228e23 (diff)
downloadports-5ad9370d00c7ff73740ca6bb603b138092da3447.tar.gz
ports-5ad9370d00c7ff73740ca6bb603b138092da3447.zip
math/py-pandas: Update to 0.22.0
PR: 225205 Submitted by: John W. O'Brien <john@saltant.com> (maintainer)
Notes
Notes: svn path=/head/; revision=459180
Diffstat (limited to 'math/py-pandas')
-rw-r--r--math/py-pandas/Makefile8
-rw-r--r--math/py-pandas/distinfo6
-rw-r--r--math/py-pandas/files/patch-GH1871961
3 files changed, 68 insertions, 7 deletions
diff --git a/math/py-pandas/Makefile b/math/py-pandas/Makefile
index e31243837b29..5f9d7879e292 100644
--- a/math/py-pandas/Makefile
+++ b/math/py-pandas/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= pandas
-DISTVERSION= 0.21.1
+DISTVERSION= 0.22.0
CATEGORIES= math devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -51,9 +51,9 @@ SQL_DESC= SQLAlchemy ORM Add-ons
HTML_DESC= HTML Parsing/Generation Add-ons
EXCEL_DESC= MS Excel I/O Add-ons
-MPL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${FLAVOR}
-SCIPY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${FLAVOR}
-BTLNCK_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bottleneck>0:math/py-bottleneck@${FLAVOR}
+MPL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>1.4.3:math/py-matplotlib@${FLAVOR}
+SCIPY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scipy>0.14.0:science/py-scipy@${FLAVOR}
+BTLNCK_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bottleneck>1.0.0:math/py-bottleneck@${FLAVOR}
NUMEXPR_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numexpr>=2.4.6:math/py-numexpr@${FLAVOR}
BOTO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto>0:devel/py-boto@${FLAVOR}
TABLES_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tables>=3.0.0:devel/py-tables@${FLAVOR}
diff --git a/math/py-pandas/distinfo b/math/py-pandas/distinfo
index d689ab8c01d1..5ed28223e3e7 100644
--- a/math/py-pandas/distinfo
+++ b/math/py-pandas/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1514141635
-SHA256 (pandas-0.21.1.tar.gz) = c5f5cba88bf0659554c41c909e1f78139f6fce8fa9315a29a23692b38ff9788a
-SIZE (pandas-0.21.1.tar.gz) = 11288319
+TIMESTAMP = 1516038682
+SHA256 (pandas-0.22.0.tar.gz) = 44a94091dd71f05922eec661638ec1a35f26d573c119aa2fad964f10a2880e6c
+SIZE (pandas-0.22.0.tar.gz) = 11297071
diff --git a/math/py-pandas/files/patch-GH18719 b/math/py-pandas/files/patch-GH18719
new file mode 100644
index 000000000000..5063af1d0fe6
--- /dev/null
+++ b/math/py-pandas/files/patch-GH18719
@@ -0,0 +1,61 @@
+commit c753e1e08b01a438aaa252327de046109bf4bcfd
+Author: Joris Van den Bossche <jorisvandenbossche@gmail.com>
+Date: Mon Dec 11 11:57:00 2017 +0100
+
+ TST: make it possible to run tests without moto installed (#18719)
+
+diff pandas/tests/io/conftest.py pandas/tests/io/conftest.py
+--- pandas/tests/io/conftest.py.orig 2017-12-11 10:57:00 UTC
++++ pandas/tests/io/conftest.py
+@@ -1,6 +1,5 @@
+ import os
+
+-import moto
+ import pytest
+ from pandas.io.parsers import read_table
+
+@@ -42,6 +41,7 @@ def s3_resource(tips_file, jsonl_file):
+ is yielded by the fixture.
+ """
+ pytest.importorskip('s3fs')
++ moto = pytest.importorskip('moto')
+ moto.mock_s3().start()
+
+ test_s3_files = [
+diff pandas/tests/io/json/test_compression.py pandas/tests/io/json/test_compression.py
+--- pandas/tests/io/json/test_compression.py.orig 2017-12-11 10:57:00 UTC
++++ pandas/tests/io/json/test_compression.py
+@@ -1,5 +1,4 @@
+ import pytest
+-import moto
+
+ import pandas as pd
+ from pandas import compat
+@@ -73,6 +72,8 @@ def test_read_zipped_json():
+ def test_with_s3_url(compression):
+ boto3 = pytest.importorskip('boto3')
+ pytest.importorskip('s3fs')
++ moto = pytest.importorskip('moto')
++
+ if compression == 'xz':
+ tm._skip_if_no_lzma()
+
+diff pandas/tests/io/test_excel.py pandas/tests/io/test_excel.py
+--- pandas/tests/io/test_excel.py.orig 2017-12-11 10:57:00 UTC
++++ pandas/tests/io/test_excel.py
+@@ -10,7 +10,6 @@ from warnings import catch_warnings
+ import numpy as np
+ import pytest
+ from numpy import nan
+-import moto
+
+ import pandas as pd
+ import pandas.util.testing as tm
+@@ -616,6 +615,7 @@ class XlrdTests(ReadingTestsBase):
+ def test_read_from_s3_url(self):
+ boto3 = pytest.importorskip('boto3')
+ pytest.importorskip('s3fs')
++ moto = pytest.importorskip('moto')
+
+ with moto.mock_s3():
+ conn = boto3.resource("s3", region_name="us-east-1")