aboutsummaryrefslogtreecommitdiff
path: root/math/py-permutation
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-06-17 20:07:07 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-06-17 20:07:07 +0000
commita022a94478671257535dc97ad6482b0e838fb06a (patch)
tree2002570b0ead67a5972d497217d0691ad984cb01 /math/py-permutation
parent2e608536ce410a4145578263b3ca4291bd5db5ee (diff)
downloadports-a022a94478671257535dc97ad6482b0e838fb06a.tar.gz
ports-a022a94478671257535dc97ad6482b0e838fb06a.zip
New port: math/py-permutation: Permutations of finitely many positive integers
Notes
Notes: svn path=/head/; revision=472631
Diffstat (limited to 'math/py-permutation')
-rw-r--r--math/py-permutation/Makefile22
-rw-r--r--math/py-permutation/distinfo3
-rw-r--r--math/py-permutation/pkg-descr7
3 files changed, 32 insertions, 0 deletions
diff --git a/math/py-permutation/Makefile b/math/py-permutation/Makefile
new file mode 100644
index 000000000000..b70cfd769d3a
--- /dev/null
+++ b/math/py-permutation/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= permutation
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.0-2
+DISTVERSIONSUFFIX= -g42654bb
+CATEGORIES= math python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Permutations of finitely many positive integers
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= jwodder
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-permutation/distinfo b/math/py-permutation/distinfo
new file mode 100644
index 000000000000..d0fa8a1fd1c9
--- /dev/null
+++ b/math/py-permutation/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1529265718
+SHA256 (jwodder-permutation-v0.1.0-2-g42654bb_GH0.tar.gz) = 20419731be9aaba9efa74842769c88f8db3da3be83779e77cbf0fb42c386b10c
+SIZE (jwodder-permutation-v0.1.0-2-g42654bb_GH0.tar.gz) = 12979
diff --git a/math/py-permutation/pkg-descr b/math/py-permutation/pkg-descr
new file mode 100644
index 000000000000..222708f72422
--- /dev/null
+++ b/math/py-permutation/pkg-descr
@@ -0,0 +1,7 @@
+permutation provides a Permutation class for representing permutations of
+finitely many positive integers in Python. Supported operations & properties
+include inverses, (group theoretic) order, parity, composition/multiplication,
+cycle decomposition, cycle notation, word representation, Lehmer codes, and,
+of course, use as a callable on integers.
+
+WWW: https://github.com/jwodder/permutation