aboutsummaryrefslogtreecommitdiff
path: root/math/py-pplpy/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-01-20 21:08:29 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-01-20 21:08:29 +0000
commita772b00a19e15f48650194e09f01225820614d1a (patch)
tree0e463f5f3eee0fee827fcbbbf066c9b33c171e7e /math/py-pplpy/Makefile
parentfe726971f3c316f4eaf9d78d9c6cf80f05741e40 (diff)
downloadports-a772b00a19e15f48650194e09f01225820614d1a.tar.gz
ports-a772b00a19e15f48650194e09f01225820614d1a.zip
- Upgrade to 0.8.7
- clang 11 is now supported - Strip the libraries - Add a test target.
Notes
Notes: svn path=/head/; revision=562159
Diffstat (limited to 'math/py-pplpy/Makefile')
-rw-r--r--math/py-pplpy/Makefile23
1 files changed, 10 insertions, 13 deletions
diff --git a/math/py-pplpy/Makefile b/math/py-pplpy/Makefile
index 3a4aae6b39da..80cfabc4105e 100644
--- a/math/py-pplpy/Makefile
+++ b/math/py-pplpy/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pplpy
-PORTVERSION= 0.8.4
-PORTREVISION= 2
+PORTVERSION= 0.8.7
CATEGORIES= math python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -22,25 +21,20 @@ LIB_DEPENDS= libgmp.so:math/gmp \
libppl.so:devel/ppl
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gmpy2-devel>0:math/py-gmpy2-devel@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cysignals>0:devel/py-cysignals@${PY_FLAVOR}
+TEST_DEPENDS= py.test:devel/py-pytest@${PY_FLAVOR}
USES= compiler:c++11-lang localbase python:3.6+
USE_PYTHON= cython distutils
+.if !defined(WITH_DEBUG)
+LDFLAGS+= -s
+.endif
+
OPTIONS_DEFINE= DOCS
DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0,1:textproc/py-sphinx@${PY_FLAVOR}
DOCS_USES= gmake
PORTDOCS= *
-.include <bsd.port.pre.mk>
-
-.if ${COMPILER_TYPE} == "clang" && ${COMPILER_VERSION} >= 110
-# error: cannot initialize a parameter of type 'bool' with an rvalue of type 'nullptr_t'
-BUILD_DEPENDS+= ${LOCALBASE}/bin/clang10:devel/llvm10
-CPP= ${LOCALBASE}/bin/clang-cpp10
-CC= ${LOCALBASE}/bin/clang10
-CXX= ${LOCALBASE}/bin/clang++10
-.endif
-
do-build-DOCS-on:
(cd ${WRKSRC}/docs && ${GMAKE} html)
@@ -48,4 +42,7 @@ post-build-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${CP} -R ${WRKSRC}/docs/build/html/* ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+do-test: install
+ (cd ${WRKSRC} && py.test)
+
+.include <bsd.port.mk>