aboutsummaryrefslogtreecommitdiff
path: root/math/py-primme
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-28 04:33:28 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-28 04:33:28 +0000
commit15bff4e89cf9b3888dac6f47e4a6751fc81e1000 (patch)
tree80a22f3fa20b5fdf109f62927278c44623829123 /math/py-primme
parent1dbf74e111d6ade3c691f2f5afb4ef1ea99d949b (diff)
downloadports-15bff4e89cf9b3888dac6f47e4a6751fc81e1000.tar.gz
ports-15bff4e89cf9b3888dac6f47e4a6751fc81e1000.zip
math/py-primme: Update 2.1.5.20181011 -> 2.2
Reported by: portscout
Notes
Notes: svn path=/head/; revision=483220
Diffstat (limited to 'math/py-primme')
-rw-r--r--math/py-primme/Makefile9
-rw-r--r--math/py-primme/distinfo6
-rw-r--r--math/py-primme/files/patch-setup.py6
3 files changed, 12 insertions, 9 deletions
diff --git a/math/py-primme/Makefile b/math/py-primme/Makefile
index 5f1fbd99e431..ff74d56fe6c5 100644
--- a/math/py-primme/Makefile
+++ b/math/py-primme/Makefile
@@ -1,7 +1,8 @@
# $FreeBSD$
PORTNAME= primme
-DISTVERSION= 2.1.5.20181011 # need the latest changes, but github repo is mistagged, no regular github tag available
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.2
CATEGORIES= math python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,14 +20,16 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose@${PY_FLAVOR}
USES= fortran gmake localbase:ldflags python shebangfix
SHEBANG_FILES= examples.py tests.py
USE_GITHUB= yes
-GH_TAGNAME= 6a0fa27
USE_PYTHON= distutils autoplist
TEST_TARGET= test
WRKSRC_SUBDIR= Python
BINARY_ALIAS= python2=${PYTHON_CMD}
-post-test: # not sure why does the 'test' target tun examples and not tests
+post-patch:
+ @${REINPLACE_CMD} "s|\['../lib/libprimme.a'\]|['${LOCALBASE}/lib/libprimme.so']|" ${WRKSRC}/setup.py
+
+post-test: # not sure why does the 'test' target run examples and not tests
@cd ${WRKSRC} && ${PYTHON_CMD} ${WRKSRC}/tests.py
.include <bsd.port.mk>
diff --git a/math/py-primme/distinfo b/math/py-primme/distinfo
index 4e33cdc8c396..78a2bb297a97 100644
--- a/math/py-primme/distinfo
+++ b/math/py-primme/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1539307207
-SHA256 (primme-primme-2.1.5.20181011-6a0fa27_GH0.tar.gz) = 8f662a7c41d5bfb7910ccb9bbcb7f06f1191fc7c7a9d41fb695e9b13438bcb79
-SIZE (primme-primme-2.1.5.20181011-6a0fa27_GH0.tar.gz) = 5511173
+TIMESTAMP = 1540699958
+SHA256 (primme-primme-v2.2_GH0.tar.gz) = 5ed1b4476659cb0d0ef1de4f00bbd3fa9e1d879f067890a08236dcb48d8e6a52
+SIZE (primme-primme-v2.2_GH0.tar.gz) = 6161380
diff --git a/math/py-primme/files/patch-setup.py b/math/py-primme/files/patch-setup.py
index c1531c348260..7beb0297e2aa 100644
--- a/math/py-primme/files/patch-setup.py
+++ b/math/py-primme/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2018-10-11 23:38:33 UTC
+--- setup.py.orig 2018-10-26 18:03:19 UTC
+++ setup.py
-@@ -15,31 +16,33 @@ def get_numpy_options():
+@@ -16,31 +16,33 @@ def get_numpy_options():
numpy_include = numpy.get_include()
# Obtain BLAS/LAPACK linking options
@@ -56,5 +56,5 @@
+ blaslapack_extra_link_args = []
+ blaslapack_library_dirs = []
- return dict(
+ r = dict(
include_dirs = [numpy_include, "primme/include", "primme/src/include"],