aboutsummaryrefslogtreecommitdiff
path: root/math/py-pycosat
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-08-25 11:10:03 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-08-25 11:10:03 +0000
commit19094cd53d0b198fa023c5c3d8adabf03e623a01 (patch)
tree6898effce91a7f174db4ff6ce39990f3074fd3a3 /math/py-pycosat
parentf24c8dd211cc3b2f69ac486c7f4f63f9f5e5fbb0 (diff)
downloadports-19094cd53d0b198fa023c5c3d8adabf03e623a01.tar.gz
ports-19094cd53d0b198fa023c5c3d8adabf03e623a01.zip
Move picosat and py-pycosat from devel -> math
- Remove from devel/Makefile - Add to math/Makefile - Update CATEGORIES for both ports - Add MOVED entries While I'm here, sort MOVED entries causing MOVEDlint.awk error [1] after r365599 [2] [1] 6470: date going backwards from 2014-08-20 to 2014-08-15 [2] https://svnweb.freebsd.org/changeset/ports/365599 Suggested by: vsevolod
Notes
Notes: svn path=/head/; revision=366063
Diffstat (limited to 'math/py-pycosat')
-rw-r--r--math/py-pycosat/Makefile32
-rw-r--r--math/py-pycosat/distinfo2
-rw-r--r--math/py-pycosat/files/patch-setup.py8
-rw-r--r--math/py-pycosat/pkg-descr6
4 files changed, 48 insertions, 0 deletions
diff --git a/math/py-pycosat/Makefile b/math/py-pycosat/Makefile
new file mode 100644
index 000000000000..81478b0ecdc4
--- /dev/null
+++ b/math/py-pycosat/Makefile
@@ -0,0 +1,32 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pycosat
+PORTVERSION= 0.6.0
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Bindings to PicoSAT (a SAT solver)
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libpicosat.so:${PORTSDIR}/devel/picosat
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+PYDISTUTILS_BUILDARGS= build_ext \
+ -I${LOCALBASE}/include -L${LOCALBASE}/lib \
+ -DDONT_INCLUDE_PICOSAT \
+ -lpicosat
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/python2.7/site-packages/pycosat.so
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>
diff --git a/math/py-pycosat/distinfo b/math/py-pycosat/distinfo
new file mode 100644
index 000000000000..873e0bd37d05
--- /dev/null
+++ b/math/py-pycosat/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pycosat-0.6.0.tar.gz) = 9ce71131cedb6dcb9a64896c1998e77f8e1e211825d8aacba8994a9492b04d0b
+SIZE (pycosat-0.6.0.tar.gz) = 58324
diff --git a/math/py-pycosat/files/patch-setup.py b/math/py-pycosat/files/patch-setup.py
new file mode 100644
index 000000000000..651ed354c6d8
--- /dev/null
+++ b/math/py-pycosat/files/patch-setup.py
@@ -0,0 +1,8 @@
+--- ./setup.py.orig 2014-08-08 18:54:35.336077625 +1000
++++ ./setup.py 2014-08-08 18:54:46.442391757 +1000
+@@ -43,4 +43,5 @@
+ py_modules = ['test_pycosat'],
+ description = "bindings to picosat (a SAT solver)",
+ long_description = open('README.rst').read(),
++ test_suite="test_pycosat",
+ )
diff --git a/math/py-pycosat/pkg-descr b/math/py-pycosat/pkg-descr
new file mode 100644
index 000000000000..81525e110969
--- /dev/null
+++ b/math/py-pycosat/pkg-descr
@@ -0,0 +1,6 @@
+PicoSAT is a popular SAT solver written by Armin Biere in pure C. This
+package provides efficient Python bindings to picosat on the C level,
+i.e. when importing pycosat, the picosat solver becomes part of the
+Python process itself.
+
+WWW: https://github.com/ContinuumIO/pycosat