aboutsummaryrefslogtreecommitdiff
path: root/math/py-pyodesys/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-21 16:41:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-21 16:41:49 +0000
commit31ed0234b5da5848a11cbf3a932be1f4902cee6b (patch)
tree795d8b5108444b70a043be4d3b8909df65f2735c /math/py-pyodesys/Makefile
parente681b893285177cfcf3daa754a7f00b4baf9d898 (diff)
downloadports-31ed0234b5da5848a11cbf3a932be1f4902cee6b.tar.gz
ports-31ed0234b5da5848a11cbf3a932be1f4902cee6b.zip
math/py-pyodesys: Update 0.14.0 -> 0.14.1
Reported by: portscout
Diffstat (limited to 'math/py-pyodesys/Makefile')
-rw-r--r--math/py-pyodesys/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/math/py-pyodesys/Makefile b/math/py-pyodesys/Makefile
index fa6f9e7836fa..31778f9ba0be 100644
--- a/math/py-pyodesys/Makefile
+++ b/math/py-pyodesys/Makefile
@@ -1,5 +1,5 @@
PORTNAME= pyodesys
-DISTVERSION= 0.14.0
+DISTVERSION= 0.14.1
CATEGORIES= math python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,17 +11,24 @@ LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}matplotlib>=2.2.2:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=2.2.5:math/py-matplotlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}notebook>=5.7.8:www/py-notebook@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>=1.2.3:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sym>=0.3.4:math/py-sym@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sympy>=1.5.1:math/py-sympy@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${LOCALBASE}/include/boost/numeric/ublas/matrix.hpp:devel/boost-libs \
+ ${LOCALBASE}/include/gsl/gsl_errno.h:math/gsl
-USES= python:3.7+
+USES= localbase:ldflags python:3.7+ shebangfix
USE_PYTHON= distutils autoplist
+
+SHEBANG_GLOB= *.py
+
NO_ARCH= yes
+BINARY_ALIAS= python3=${PYTHON_CMD}
+
OPTIONS_DEFINE= EXTRAS
OPTIONS_DEFAULT= EXTRAS
@@ -32,7 +39,7 @@ EXTRAS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>0:devel/py-appdirs@${PY_FLAVO
${PYTHON_PKGNAMEPREFIX}pygslodeiv2>=0.9.1:math/py-pygslodeiv2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyodeint>=0.10.1:math/py-pyodeint@${PY_FLAVOR}
-do-test: # Tests fail because extra-dependencies are erroneously required: https://github.com/bjodah/pyodesys/issues/97
- @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest
+do-test: install # Tests fail because extra-dependencies are erroneously required: https://github.com/bjodah/pyodesys/issues/97
+ @cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest
.include <bsd.port.mk>