aboutsummaryrefslogtreecommitdiff
path: root/math/py-pyodesys/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-04-01 06:24:52 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-04-01 06:24:52 +0000
commit4d6f7a79a49154613836011ebea709109ea33ac7 (patch)
treee27af371296c713c228bb78960f8d15e48a8cedc /math/py-pyodesys/Makefile
parentef675b6e39ecb0036fc7694bce843b9acf92f2cd (diff)
downloadports-4d6f7a79a49154613836011ebea709109ea33ac7.tar.gz
ports-4d6f7a79a49154613836011ebea709109ea33ac7.zip
New port: math/py-pyodesys: Straightforward numerical integration of ODE systems from Python
Notes
Notes: svn path=/head/; revision=466121
Diffstat (limited to 'math/py-pyodesys/Makefile')
-rw-r--r--math/py-pyodesys/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/math/py-pyodesys/Makefile b/math/py-pyodesys/Makefile
new file mode 100644
index 000000000000..59bb94fe61b7
--- /dev/null
+++ b/math/py-pyodesys/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= pyodesys
+DISTVERSION= 0.11.9
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Straightforward numerical integration of ODE systems from Python
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sym>=0.3.1:math/py-sym@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sympy>=1.1.1:math/py-sympy@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>