aboutsummaryrefslogtreecommitdiff
path: root/math/py-pyodesys/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-26 14:42:03 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-27 11:42:12 +0000
commitc45ba2de94ea5e5f4b00a98b76c75c35b8d8eacb (patch)
tree05549a2d768a813b033063df72a322386fa1219c /math/py-pyodesys/Makefile
parentd7176a1b200c18e8db3c4728de0c1cb5bb170b99 (diff)
downloadports-c45ba2de94ea5e5f4b00a98b76c75c35b8d8eacb.tar.gz
ports-c45ba2de94ea5e5f4b00a98b76c75c35b8d8eacb.zip
math/py-pyodesys: switch to USES=pytest, fix tests
Reported by: reprise Approved by: portmgr blanket
Diffstat (limited to 'math/py-pyodesys/Makefile')
-rw-r--r--math/py-pyodesys/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/math/py-pyodesys/Makefile b/math/py-pyodesys/Makefile
index 31778f9ba0be..1b99f6cd60c9 100644
--- a/math/py-pyodesys/Makefile
+++ b/math/py-pyodesys/Makefile
@@ -16,11 +16,10 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>=1.2.3:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sym>=0.3.4:math/py-sym@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sympy>=1.5.1:math/py-sympy@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
- ${LOCALBASE}/include/boost/numeric/ublas/matrix.hpp:devel/boost-libs \
+TEST_DEPENDS= ${LOCALBASE}/include/boost/numeric/ublas/matrix.hpp:devel/boost-libs \
${LOCALBASE}/include/gsl/gsl_errno.h:math/gsl
-USES= localbase:ldflags python:3.7+ shebangfix
+USES= display:test localbase:ldflags python:3.7+ shebangfix pytest
USE_PYTHON= distutils autoplist
SHEBANG_GLOB= *.py
@@ -39,7 +38,4 @@ EXTRAS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>0:devel/py-appdirs@${PY_FLAVO
${PYTHON_PKGNAMEPREFIX}pygslodeiv2>=0.9.1:math/py-pygslodeiv2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyodeint>=0.10.1:math/py-pyodeint@${PY_FLAVOR}
-do-test: install # Tests fail because extra-dependencies are erroneously required: https://github.com/bjodah/pyodesys/issues/97
- @cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest
-
.include <bsd.port.mk>