aboutsummaryrefslogtreecommitdiff
path: root/math/py-pysmt
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2020-03-08 16:18:05 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2020-03-08 16:18:05 +0000
commit0480db5e0be5f7b0bae0bddec7ee9997bcc01e32 (patch)
treeb375832b881cbbb0fa4af0c4d41750663f48b678 /math/py-pysmt
parent9b6e243a4967c0f587ee858f9c7df1e28b877570 (diff)
downloadports-0480db5e0be5f7b0bae0bddec7ee9997bcc01e32.tar.gz
ports-0480db5e0be5f7b0bae0bddec7ee9997bcc01e32.zip
Rename math/py-PySMT to math/py-pysmt
This is done in order to follow the policy set out by the Python team: https://wiki.freebsd.org/Python/PortsPolicy#PORTNAME Reported by: koobs
Notes
Notes: svn path=/head/; revision=528050
Diffstat (limited to 'math/py-pysmt')
-rw-r--r--math/py-pysmt/Makefile29
-rw-r--r--math/py-pysmt/distinfo3
-rw-r--r--math/py-pysmt/pkg-descr22
3 files changed, 54 insertions, 0 deletions
diff --git a/math/py-pysmt/Makefile b/math/py-pysmt/Makefile
new file mode 100644
index 000000000000..61cd8796d4ae
--- /dev/null
+++ b/math/py-pysmt/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= pysmt
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.8.0
+CATEGORIES= math python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Solver-agnostic library for SMT formulae manipulation and solving
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR}
+
+# Supported Python versions: 2.7,3.5+
+USES= python
+USE_GITHUB= yes
+USE_PYTHON= autoplist concurrent distutils
+PYDISTUTILS_PKGNAME= PySMT
+
+NO_ARCH= yes
+
+do-test:
+ @(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} nosetests-${PYTHON_VER} -v)
+
+.include <bsd.port.mk>
diff --git a/math/py-pysmt/distinfo b/math/py-pysmt/distinfo
new file mode 100644
index 000000000000..0b4ec99ad8f6
--- /dev/null
+++ b/math/py-pysmt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1583537787
+SHA256 (pysmt-pysmt-v0.8.0_GH0.tar.gz) = 6a1f2ea69e97c9cecb43f9c5b3c5d786568cb26a3ebabe8c2b4e0acbd1870b94
+SIZE (pysmt-pysmt-v0.8.0_GH0.tar.gz) = 1129930
diff --git a/math/py-pysmt/pkg-descr b/math/py-pysmt/pkg-descr
new file mode 100644
index 000000000000..1907b331491f
--- /dev/null
+++ b/math/py-pysmt/pkg-descr
@@ -0,0 +1,22 @@
+pySMT is a library for SMT formulae manipulation and solving, which makes
+working with Satisfiability Modulo Theory simple.
+
+Among others, the user can:
+
+- Define formulae in a solver independent way in a simple and inutitive way,
+- Write ad-hoc simplifiers and operators,
+- Dump your problems in the SMT-Lib format,
+- Solve them using one of the native solvers, or by wrapping any SMT-Lib
+ complaint solver.
+
+pySMT provides methods to define a formula in Linear Real Arithmetic (LRA),
+Real Difference Logic (RDL), their combination (LIRA), Equalities and
+Uninterpreted Functions (EUF), Bit-Vectors (BV), and Arrays (A). The following
+solvers are supported through native APIs: MathSAT, Z3, CVC4, Yices, CUDD,
+PicoSAT, and Boolector. Additionally, you can use any SMT-LIB 2 compliant
+solver.
+
+PySMT assumes that the python bindings for the SMT Solver are installed and
+accessible from your PYTHONPATH.
+
+WWW: http://www.pysmt.org