aboutsummaryrefslogtreecommitdiff
path: root/math/py-python-louvain
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-30 06:18:48 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-30 06:18:48 +0000
commit3c6cb08c46fecbf89c9c02b2667defb18b49eafe (patch)
treef829f2f60fba6548a652b01d3d7309967b85c5ed /math/py-python-louvain
parentfccee7d7fda2fd42ff8aa359aa70d7b135d8eb27 (diff)
downloadports-3c6cb08c46fecbf89c9c02b2667defb18b49eafe.tar.gz
ports-3c6cb08c46fecbf89c9c02b2667defb18b49eafe.zip
New port: math/py-python-louvain: Louvain algorithm for community detection
Notes
Notes: svn path=/head/; revision=483453
Diffstat (limited to 'math/py-python-louvain')
-rw-r--r--math/py-python-louvain/Makefile21
-rw-r--r--math/py-python-louvain/distinfo3
-rw-r--r--math/py-python-louvain/pkg-descr7
3 files changed, 31 insertions, 0 deletions
diff --git a/math/py-python-louvain/Makefile b/math/py-python-louvain/Makefile
new file mode 100644
index 000000000000..376788e0a318
--- /dev/null
+++ b/math/py-python-louvain/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= python-louvain
+DISTVERSION= 0.11
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Louvain algorithm for community detection
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}networkx>0:math/py-networkx@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils concurrent autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-python-louvain/distinfo b/math/py-python-louvain/distinfo
new file mode 100644
index 000000000000..a0f22acd25ee
--- /dev/null
+++ b/math/py-python-louvain/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1540879709
+SHA256 (python-louvain-0.11.tar.gz) = 2ce7143f8d2bb4693a84dc0046dbf94dc576c9f6030f518f73c4420bfb2a442a
+SIZE (python-louvain-0.11.tar.gz) = 6648
diff --git a/math/py-python-louvain/pkg-descr b/math/py-python-louvain/pkg-descr
new file mode 100644
index 000000000000..9ffe51e92ecf
--- /dev/null
+++ b/math/py-python-louvain/pkg-descr
@@ -0,0 +1,7 @@
+This module implements community detection.
+
+It uses the louvain method described in Fast unfolding of communities in large
+networks, Vincent D Blondel, Jean-Loup Guillaume, Renaud Lambiotte, Renaud
+Lefebvre, Journal of Statistical Mechanics: Theory and Experiment 2008(10).
+
+WWW: https://github.com/taynaud/python-louvain