aboutsummaryrefslogtreecommitdiff
path: root/math/py-qdldl
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-01-07 00:46:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-01-07 00:46:21 +0000
commit5708a9548bb7998271d5cc12b048364349c95ca2 (patch)
tree74b516f3ffc7533bc13a91be33dd96442d4ba182 /math/py-qdldl
parent303732cb30f2d897b4a80f6707c991ff659cd8c2 (diff)
downloadports-5708a9548bb7998271d5cc12b048364349c95ca2.tar.gz
ports-5708a9548bb7998271d5cc12b048364349c95ca2.zip
New port: math/py-qdldl: QDLDL free LDL factorization routine for linear systems: Ax = b
Notes
Notes: svn path=/head/; revision=560660
Diffstat (limited to 'math/py-qdldl')
-rw-r--r--math/py-qdldl/Makefile23
-rw-r--r--math/py-qdldl/distinfo3
-rw-r--r--math/py-qdldl/pkg-descr4
3 files changed, 30 insertions, 0 deletions
diff --git a/math/py-qdldl/Makefile b/math/py-qdldl/Makefile
new file mode 100644
index 000000000000..04cac040a3a7
--- /dev/null
+++ b/math/py-qdldl/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= qdldl
+DISTVERSION= 0.1.5.post0
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= QDLDL free LDL factorization routine for linear systems: Ax = b
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pybind11>0:devel/py-pybind11@${PY_FLAVOR} \
+ cmake:devel/cmake
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.13.2:science/py-scipy@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/math/py-qdldl/distinfo b/math/py-qdldl/distinfo
new file mode 100644
index 000000000000..4c00f834170f
--- /dev/null
+++ b/math/py-qdldl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1609978323
+SHA256 (qdldl-0.1.5.post0.tar.gz) = c392c7427651d8b226423c7aba4a0f2338a1f38a4bbdabac6bc4afd8bc934f06
+SIZE (qdldl-0.1.5.post0.tar.gz) = 69127
diff --git a/math/py-qdldl/pkg-descr b/math/py-qdldl/pkg-descr
new file mode 100644
index 000000000000..50d822b167a8
--- /dev/null
+++ b/math/py-qdldl/pkg-descr
@@ -0,0 +1,4 @@
+Python interface to the QDLDL free LDL factorization routine for quasi-definite
+linear systems: Ax = b.
+
+WWW: https://github.com/oxfordcontrol/qdldl-python/