aboutsummaryrefslogtreecommitdiff
path: root/math/py-qdldl
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2021-01-08 12:51:12 +0000
committerMark Linimon <linimon@FreeBSD.org>2021-01-08 12:51:12 +0000
commitbf01f8c0546ed0102ecbbe1fda61987cb3b396bd (patch)
treeff4a43815c36cae26cb30242187783aed51c27dc /math/py-qdldl
parent7863df3dd179643783cec9629a140a4c15051cc0 (diff)
downloadports-bf01f8c0546ed0102ecbbe1fda61987cb3b396bd.tar.gz
ports-bf01f8c0546ed0102ecbbe1fda61987cb3b396bd.zip
Add compiler:c++11-lang to USES to fix build on GCC-based systems:
/wrkdirs/usr/ports/math/py-qdldl/work-py37/qdldl-0.1.5.post0/c/amd/src/perm.c:23: error: 'for' loop initial declaration used outside C99 mode cc1plus: error: unrecognized command line option "-std=c++11" Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=560768
Diffstat (limited to 'math/py-qdldl')
-rw-r--r--math/py-qdldl/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/math/py-qdldl/Makefile b/math/py-qdldl/Makefile
index 5308216c678a..8130849d6f79 100644
--- a/math/py-qdldl/Makefile
+++ b/math/py-qdldl/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pybind11>0:devel/py-pybind11@${PY_FLAVOR}
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.13.2:science/py-scipy@${PY_FLAVOR}
-USES= python:3.6+
+USES= compiler:c++11-lang python:3.6+
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>