aboutsummaryrefslogtreecommitdiff
path: root/math/py-rpy2
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-05-15 15:56:06 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-05-15 15:56:06 +0000
commit8aa4e65d3bba12d0b4d50698dcd36ad4d8839e1c (patch)
treef9f9da87ec02ff84eba13ac04143be1df81c2895 /math/py-rpy2
parent24bd3bff7b4586c3235b4231e599afa26696b99f (diff)
downloadports-8aa4e65d3bba12d0b4d50698dcd36ad4d8839e1c.tar.gz
ports-8aa4e65d3bba12d0b4d50698dcd36ad4d8839e1c.zip
Fix runtime system detection
- Bump PORTREVISION for package change PR: 237736 Submitted by: yuri, Rainer Hurling <rhurlin@gwdg.de>
Notes
Notes: svn path=/head/; revision=501733
Diffstat (limited to 'math/py-rpy2')
-rw-r--r--math/py-rpy2/Makefile1
-rw-r--r--math/py-rpy2/files/patch-rpy-situation.py11
2 files changed, 12 insertions, 0 deletions
diff --git a/math/py-rpy2/Makefile b/math/py-rpy2/Makefile
index 2af1afe95b57..6c770682e29a 100644
--- a/math/py-rpy2/Makefile
+++ b/math/py-rpy2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rpy2
DISTVERSION= 3.0.3
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/math/py-rpy2/files/patch-rpy-situation.py b/math/py-rpy2/files/patch-rpy-situation.py
new file mode 100644
index 000000000000..474f0827b7f5
--- /dev/null
+++ b/math/py-rpy2/files/patch-rpy-situation.py
@@ -0,0 +1,11 @@
+--- rpy/situation.py.orig 2019-05-05 16:29:19 UTC
++++ rpy/situation.py
+@@ -63,7 +63,7 @@ def r_home_from_registry():
+
+ def get_rlib_path(r_home: str, system: str) -> str:
+ """Get the path for the R shared library."""
+- if system == 'Linux':
++ if system == 'FreeBSD' or system == 'Linux':
+ lib_path = os.path.join(r_home, 'lib', 'libR.so')
+ elif system == 'Darwin':
+ lib_path = os.path.join(r_home, 'lib', 'libR.dylib')