aboutsummaryrefslogtreecommitdiff
path: root/math/py-splot
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-03 19:57:38 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-03 19:57:38 +0000
commitcb334d402f363592f0497c0991655df76a86ab15 (patch)
tree515b1b8b28c8c706f3dc8eaceb50328640da0963 /math/py-splot
parent019265d708d4f3642103e081b46e87283de73c83 (diff)
downloadports-cb334d402f363592f0497c0991655df76a86ab15.tar.gz
ports-cb334d402f363592f0497c0991655df76a86ab15.zip
Add py-splot 1.1.3
splot provides PySAL users with a lightweight visualization interface to explore their data and quickly iterate through static and dynamic visualisations. splot connects spatial analysis done in PySAL to different popular visualization toolkits like matplotlib. The splot package allows you to create both static plots ready for publication and interactive visualizations for quick iteration and spatial data exploration. The primary goal of splot is to enable you to visualize popular PySAL objects and gives you different views on your spatial analysis workflow. WWW: https://splot.readthedocs.io/en/latest/ WWW: https://github.com/pysal/splot
Notes
Notes: svn path=/head/; revision=560047
Diffstat (limited to 'math/py-splot')
-rw-r--r--math/py-splot/Makefile32
-rw-r--r--math/py-splot/distinfo3
-rw-r--r--math/py-splot/pkg-descr12
3 files changed, 47 insertions, 0 deletions
diff --git a/math/py-splot/Makefile b/math/py-splot/Makefile
new file mode 100644
index 000000000000..9ac250e6203e
--- /dev/null
+++ b/math/py-splot/Makefile
@@ -0,0 +1,32 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= splot
+PORTVERSION= 1.1.3
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Visual analytics for spatial analysis with PySAL
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}descartes>=0:graphics/py-descartes@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}esda>=0:science/py-esda@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}geopandas>=0.4.0:graphics/py-geopandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}giddy>=0:graphics/py-giddy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}libpysal>=0:science/py-libpysal@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mapclassify>=0:graphics/py-mapclassify@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}seaborn>=0:math/py-seaborn@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}spreg>=0:math/py-spreg@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-splot/distinfo b/math/py-splot/distinfo
new file mode 100644
index 000000000000..0637be8844fb
--- /dev/null
+++ b/math/py-splot/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1609598749
+SHA256 (splot-1.1.3.tar.gz) = 7be9557cd3c6c0374e07c2a149e1330318d22d6ecb420f70f1a0dbad9b3187fd
+SIZE (splot-1.1.3.tar.gz) = 34095
diff --git a/math/py-splot/pkg-descr b/math/py-splot/pkg-descr
new file mode 100644
index 000000000000..949dea8d5781
--- /dev/null
+++ b/math/py-splot/pkg-descr
@@ -0,0 +1,12 @@
+splot provides PySAL users with a lightweight visualization interface to explore
+their data and quickly iterate through static and dynamic visualisations.
+
+splot connects spatial analysis done in PySAL to different popular visualization
+toolkits like matplotlib. The splot package allows you to create both static
+plots ready for publication and interactive visualizations for quick iteration
+and spatial data exploration. The primary goal of splot is to enable you to
+visualize popular PySAL objects and gives you different views on your spatial
+analysis workflow.
+
+WWW: https://splot.readthedocs.io/en/latest/
+WWW: https://github.com/pysal/splot