aboutsummaryrefslogtreecommitdiff
path: root/math/py-spot
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-08-04 23:33:34 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-08-04 23:33:34 +0000
commit9570014a753975d835354aa4b07dc4e2d1ae5a4e (patch)
tree82be46138035921bef9cb9b5ae9790bdd3f40443 /math/py-spot
parent39cfcd2f48fbfa93c238ea285b1383b944ecb635 (diff)
downloadports-9570014a753975d835354aa4b07dc4e2d1ae5a4e.tar.gz
ports-9570014a753975d835354aa4b07dc4e2d1ae5a4e.zip
Notes
Diffstat (limited to 'math/py-spot')
-rw-r--r--math/py-spot/Makefile39
-rw-r--r--math/py-spot/distinfo3
-rw-r--r--math/py-spot/files/patch-Makefile.in22
-rw-r--r--math/py-spot/pkg-descr4
-rw-r--r--math/py-spot/pkg-plist25
5 files changed, 93 insertions, 0 deletions
diff --git a/math/py-spot/Makefile b/math/py-spot/Makefile
new file mode 100644
index 000000000000..b6cc4c8dc176
--- /dev/null
+++ b/math/py-spot/Makefile
@@ -0,0 +1,39 @@
+# $FreeBSD$
+
+PORTNAME= spot
+DISTVERSION= 2.6.1
+CATEGORIES= math
+MASTER_SITES= http://www.lrde.epita.fr/dload/${PORTNAME}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python binding for 'Spot', the library for omega automata manipulation
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libspot.so:math/spot
+
+USES= compiler:c++14-lang gmake libtool python:3.4+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-python --disable-static
+INSTALL_TARGET= install-strip
+
+# otherwise shared libs aren't linked to spot libs for some reason
+LDFLAGS+= -L${LOCALBASE}/lib
+.for l in spot bddx spotgen spotltsmin
+LDFLAGS+= -l${l}
+.endfor
+
+post-configure:
+ @${REINPLACE_CMD} ' \
+ s|^BUDDY_LDFLAGS =.*|BUDDY_LDFLAGS = ${LOCALBASE}/lib/libbddx.so|; \
+ s|$$(top_builddir)/spot/libspot.la|${LOCALBASE}/lib/libspot.so|; \
+ s|$$(top_builddir)/spot/ltsmin/libspotltsmin.la|${LOCALBASE}/lib/libspotltsmin.so|; \
+ s|$$(top_builddir)/spot/gen/libspotgen.la|${LOCALBASE}/lib/libspotgen.so|' \
+ ${WRKSRC}/python/Makefile
+
+post-install:
+ @${FIND} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR} -name "*.so" | ${XARGS} ${STRIP_CMD}
+
+.include <bsd.port.mk>
diff --git a/math/py-spot/distinfo b/math/py-spot/distinfo
new file mode 100644
index 000000000000..f6b19856bf30
--- /dev/null
+++ b/math/py-spot/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1533412580
+SHA256 (spot-2.6.1.tar.gz) = 1275ec21f350ab6ae3c37a08118f5e353d67b30790fa6907d703fa2385e7f63f
+SIZE (spot-2.6.1.tar.gz) = 7088087
diff --git a/math/py-spot/files/patch-Makefile.in b/math/py-spot/files/patch-Makefile.in
new file mode 100644
index 000000000000..487034991a9c
--- /dev/null
+++ b/math/py-spot/files/patch-Makefile.in
@@ -0,0 +1,22 @@
+--- Makefile.in.orig 2018-08-04 07:35:57 UTC
++++ Makefile.in
+@@ -223,8 +223,7 @@ am__define_uniq_tagged_files = \
+ ETAGS = etags
+ CTAGS = ctags
+ CSCOPE = cscope
+-DIST_SUBDIRS = picosat buddy lib ltdl spot bin tests python doc bench \
+- elisp
++DIST_SUBDIRS = python
+ am__DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/config.h.in \
+ $(top_srcdir)/doc/org/.dir-locals.el.in \
+ $(top_srcdir)/doc/org/g++wrap.in \
+@@ -1153,8 +1152,7 @@ top_srcdir = @top_srcdir@
+ @NEVER_TRUE@NEVER_SUBDIRS = bench elisp
+ @USE_PYTHON_TRUE@PYTHON_SUBDIR = python
+ DOC_SUBDIR = doc
+-SUBDIRS = picosat buddy lib ltdl spot bin tests $(PYTHON_SUBDIR) $(DOC_SUBDIR) \
+- $(NEVER_SUBDIRS)
++SUBDIRS = $(PYTHON_SUBDIR)
+
+ UTF8 = utf8/README.md utf8/utf8.h \
+ utf8/utf8/checked.h utf8/utf8/core.h utf8/utf8/unchecked.h
diff --git a/math/py-spot/pkg-descr b/math/py-spot/pkg-descr
new file mode 100644
index 000000000000..298a4c2fb398
--- /dev/null
+++ b/math/py-spot/pkg-descr
@@ -0,0 +1,4 @@
+The python binding for 'Spot', the library for LTL, omega-automata manipulation
+and model checking.
+
+WWW: https://spot.lrde.epita.fr
diff --git a/math/py-spot/pkg-plist b/math/py-spot/pkg-plist
new file mode 100644
index 000000000000..dcc18875bdbe
--- /dev/null
+++ b/math/py-spot/pkg-plist
@@ -0,0 +1,25 @@
+%%PYTHON_SITELIBDIR%%/__pycache__/buddy.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/__pycache__/buddy.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/_buddy.so
+%%PYTHON_SITELIBDIR%%/buddy.py
+%%PYTHON_SITELIBDIR%%/spot/__init__.py
+%%PYTHON_SITELIBDIR%%/spot/__pycache__/__init__.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/spot/__pycache__/__init__.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/spot/__pycache__/aux.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/spot/__pycache__/aux.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/spot/__pycache__/gen.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/spot/__pycache__/gen.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/spot/__pycache__/impl.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/spot/__pycache__/impl.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/spot/__pycache__/jupyter.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/spot/__pycache__/jupyter.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/spot/__pycache__/ltsmin.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/spot/__pycache__/ltsmin.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/spot/_gen.so
+%%PYTHON_SITELIBDIR%%/spot/_impl.so
+%%PYTHON_SITELIBDIR%%/spot/_ltsmin.so
+%%PYTHON_SITELIBDIR%%/spot/aux.py
+%%PYTHON_SITELIBDIR%%/spot/gen.py
+%%PYTHON_SITELIBDIR%%/spot/impl.py
+%%PYTHON_SITELIBDIR%%/spot/jupyter.py
+%%PYTHON_SITELIBDIR%%/spot/ltsmin.py