aboutsummaryrefslogtreecommitdiff
path: root/math/pynac
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2020-04-18 13:54:42 +0000
committerThierry Thomas <thierry@FreeBSD.org>2020-04-18 13:54:42 +0000
commitbaada29c8161417bc9561df7cc3d1089183531b9 (patch)
tree37084b8627aef167183c908e680eee696b60cae3 /math/pynac
parentf630b46d76e9f602d9507cd6f94d59c122318f76 (diff)
downloadports-baada29c8161417bc9561df7cc3d1089183531b9.tar.gz
ports-baada29c8161417bc9561df7cc3d1089183531b9.zip
Adding pynac, a derivative of the C++ library GiNaC, which allows manipulation
of symbolic expressions. It currently provides the backend for symbolic expressions in SageMath.
Notes
Notes: svn path=/head/; revision=532032
Diffstat (limited to 'math/pynac')
-rw-r--r--math/pynac/Makefile33
-rw-r--r--math/pynac/distinfo3
-rw-r--r--math/pynac/pkg-descr6
-rw-r--r--math/pynac/pkg-plist52
4 files changed, 94 insertions, 0 deletions
diff --git a/math/pynac/Makefile b/math/pynac/Makefile
new file mode 100644
index 000000000000..4140415732ec
--- /dev/null
+++ b/math/pynac/Makefile
@@ -0,0 +1,33 @@
+# Created by: thierry@pompo.net
+# $FreeBSD$
+
+PORTNAME= pynac
+PORTVERSION= 0.7.26
+CATEGORIES= math python
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/${DISTNAME}/
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Symbolic computation with Python objects, Sage Math support library
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libgmp.so:math/gmp \
+ libntl.so:math/ntl \
+ libflint.so:math/flint2 \
+ libSingular.so:math/singular
+
+USES= compiler:c++11-lang libtool localbase pkgconfig python:3.6+ tar:bz2
+
+OPTIONS_DEFINE= GIAC
+OPTIONS_DEFAULT= GIAC
+GIAC_DESC= Use giac for polynomial manipulations
+GIAC_LIB_DEPENDS= libgiac.so:math/giacxcas
+GIAC_CONFIGURE_ON= --with-giac
+GIAC_CONFIGURE_OFF= --without-giac
+GIAC_LIBS= "-lm"
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+TEST_TARGET= check
+
+.include <bsd.port.mk>
diff --git a/math/pynac/distinfo b/math/pynac/distinfo
new file mode 100644
index 000000000000..61a0fe372b92
--- /dev/null
+++ b/math/pynac/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1587155700
+SHA256 (pynac-0.7.26.tar.bz2) = cc124ae9757355e3434ff864aeca6503184faf0642d26bc2f7bca6f3f2c9b50f
+SIZE (pynac-0.7.26.tar.bz2) = 580214
diff --git a/math/pynac/pkg-descr b/math/pynac/pkg-descr
new file mode 100644
index 000000000000..3846d248cf2a
--- /dev/null
+++ b/math/pynac/pkg-descr
@@ -0,0 +1,6 @@
+Pynac -- "Python is Not a CAS" is a modified version of Ginac that
+replaces the depency of GiNaC on CLN by a dependency instead of Python.
+It is a lite version of GiNaC as well, not implementing all the features
+of the full GiNaC, and it is *only* meant to be used as a Python library.
+
+WWW: http://pynac.org/
diff --git a/math/pynac/pkg-plist b/math/pynac/pkg-plist
new file mode 100644
index 000000000000..872c5f2dd6a4
--- /dev/null
+++ b/math/pynac/pkg-plist
@@ -0,0 +1,52 @@
+include/pynac/add.h
+include/pynac/archive.h
+include/pynac/assertion.h
+include/pynac/assume.h
+include/pynac/basic.h
+include/pynac/class_info.h
+include/pynac/cmatcher.h
+include/pynac/constant.h
+include/pynac/container.h
+include/pynac/context.h
+include/pynac/ex.h
+include/pynac/ex_utils.h
+include/pynac/expair.h
+include/pynac/expairseq.h
+include/pynac/exprseq.h
+include/pynac/extern_templates.h
+include/pynac/fderivative.h
+include/pynac/flags.h
+include/pynac/function.h
+include/pynac/ginac.h
+include/pynac/infinity.h
+include/pynac/infoflagbase.h
+include/pynac/inifcns.h
+include/pynac/lst.h
+include/pynac/matrix.h
+include/pynac/mpoly.h
+include/pynac/mul.h
+include/pynac/normal.h
+include/pynac/numeric.h
+include/pynac/operators.h
+include/pynac/optional.hpp
+include/pynac/order.h
+include/pynac/power.h
+include/pynac/print.h
+include/pynac/pseries.h
+include/pynac/ptr.h
+include/pynac/py_funcs.h
+include/pynac/registrar.h
+include/pynac/relational.h
+include/pynac/sum.h
+include/pynac/symbol.h
+include/pynac/templates.h
+include/pynac/upoly.h
+include/pynac/useries-flint.h
+include/pynac/useries.h
+include/pynac/version.h
+include/pynac/wildcard.h
+lib/libpynac.a
+lib/libpynac.so
+lib/libpynac.so.18
+lib/libpynac.so.18.3.4
+libdata/pkgconfig/pynac.pc