aboutsummaryrefslogtreecommitdiff
path: root/math/qalculate/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-08-29 17:39:02 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-08-29 17:39:02 +0000
commit37073a11e1b0bf6e3ff683873939b10465f86ad4 (patch)
treeb3372b4a32e56c4a74b6b25f6e50d754c928ca7c /math/qalculate/Makefile
parent424de77b9000f8bc411cd22393d3dce5275727a7 (diff)
downloadports-37073a11e1b0bf6e3ff683873939b10465f86ad4.tar.gz
ports-37073a11e1b0bf6e3ff683873939b10465f86ad4.zip
Notes
Diffstat (limited to 'math/qalculate/Makefile')
-rw-r--r--math/qalculate/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/math/qalculate/Makefile b/math/qalculate/Makefile
new file mode 100644
index 000000000000..1540584a5e13
--- /dev/null
+++ b/math/qalculate/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: qalculate
+# Date created: 07 July 2004
+# Whom: Sergey Akifyev <asa@gascom.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qalculate
+PORTVERSION= 0.6.3
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-gtk-${PORTVERSION}
+
+MAINTAINER= asa@gascom.ru
+COMMENT= Very powerful GUI calculator for GNOME
+
+LIB_DEPENDS= cln.3:${PORTSDIR}/math/cln
+RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot \
+ wget:${PORTSDIR}/ftp/wget
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomeprefix gnomehack intlhack libglade2 libgnome
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+# cln is built with gcc 3.3 on FreeBSD 4.x
+USE_GCC= 3.3
+# in FreeBSD 4.x struct liconv does not contain int_p_cs_precedes
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-FreeBSD4
+# XXX configure script fails to detect gettext on FreeBSD 4.x with gcc 3.3
+PLIST_SUB+= 5X="@comment "
+.else
+PLIST_SUB+= 5X=""
+.endif
+
+.include <bsd.port.post.mk>