aboutsummaryrefslogtreecommitdiff
path: root/math/qhull
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-04-28 22:27:59 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-04-28 22:27:59 +0000
commitac187f606c316bd734a297789f8ca8cb3885a99d (patch)
tree6e3c79cd7cbd8d1d7814482583861de3528e4f22 /math/qhull
parent8049f50a5dfaf7bb062c7628152ccf0b243c1ec5 (diff)
downloadports-ac187f606c316bd734a297789f8ca8cb3885a99d.tar.gz
ports-ac187f606c316bd734a297789f8ca8cb3885a99d.zip
Add qhull 1.0, qhull computes convex hulls, Delaunay triangulations
and halfspaces. Remark: submitter time-out -> maintainership assigned to ports@. PR: 63693 Submitted by: pusto@web.de
Notes
Notes: svn path=/head/; revision=107890
Diffstat (limited to 'math/qhull')
-rw-r--r--math/qhull/Makefile34
-rw-r--r--math/qhull/distinfo2
-rw-r--r--math/qhull/files/patch-configure10
-rw-r--r--math/qhull/files/patch-eg::Makefile.in11
-rw-r--r--math/qhull/files/patch-src::Makefile.in11
-rw-r--r--math/qhull/pkg-descr12
-rw-r--r--math/qhull/pkg-plist78
7 files changed, 158 insertions, 0 deletions
diff --git a/math/qhull/Makefile b/math/qhull/Makefile
new file mode 100644
index 000000000000..ebcabbe843a6
--- /dev/null
+++ b/math/qhull/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: qhull
+# Date created: 3 March 2004
+# Whom: pusto@web.de
+#
+# $FreeBSD$
+
+PORTNAME= qhull
+PORTVERSION= 1.0
+CATEGORIES= math
+MASTER_SITES= http://www.qhull.org/download/
+DISTNAME= ${PORTNAME}-2003.1
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Qhull computes convex hulls, Delaunay triangulations and halfspaces
+
+USE_REINPLACE= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+USE_LIBTOOL_VER= 13
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+.if !defined(NOPORTDOCS)
+MAN1= qhull.1 rbox.1
+.endif
+
+pre-configure:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e "s|src html eg config|src config|" \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s|install-docDATA install-examplesDATA||" \
+ ${WRKSRC}/src/Makefile.in
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/qhull/distinfo b/math/qhull/distinfo
new file mode 100644
index 000000000000..7f3551a1a9e8
--- /dev/null
+++ b/math/qhull/distinfo
@@ -0,0 +1,2 @@
+MD5 (qhull-2003.1.tar.gz) = 48228e26422bff85ef1f45df5b6e3314
+SIZE (qhull-2003.1.tar.gz) = 724313
diff --git a/math/qhull/files/patch-configure b/math/qhull/files/patch-configure
new file mode 100644
index 000000000000..5bb34aa5fe4c
--- /dev/null
+++ b/math/qhull/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Fri Feb 6 16:33:25 2004
++++ configure Wed Apr 28 23:45:04 2004
+@@ -18958,6 +18958,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/math/qhull/files/patch-eg::Makefile.in b/math/qhull/files/patch-eg::Makefile.in
new file mode 100644
index 000000000000..f9877a8061e3
--- /dev/null
+++ b/math/qhull/files/patch-eg::Makefile.in
@@ -0,0 +1,11 @@
+--- eg/Makefile.in.orig Fri Feb 6 16:33:23 2004
++++ eg/Makefile.in Wed Apr 28 23:06:27 2004
+@@ -138,7 +138,7 @@
+
+ # to:
+ docdir = $(prefix)/share/doc/$(PACKAGE)
+-examplesdir = $(docdir)/examples
++examplesdir = $(prefix)/share/examples/$(PACKAGE)
+
+ # which:
+ examples_DATA = \
diff --git a/math/qhull/files/patch-src::Makefile.in b/math/qhull/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..9623670c7d08
--- /dev/null
+++ b/math/qhull/files/patch-src::Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Fri Feb 6 16:33:23 2004
++++ src/Makefile.in Wed Apr 28 23:37:31 2004
+@@ -198,7 +198,7 @@
+
+ # to:
+ docdir = $(prefix)/share/doc/$(PACKAGE)
+-examplesdir = $(docdir)/examples
++examplesdir = $(prefix)/share/examples/$(PACKAGE)
+
+ # which:
+ examples_DATA = \
diff --git a/math/qhull/pkg-descr b/math/qhull/pkg-descr
new file mode 100644
index 000000000000..9a7aedb63908
--- /dev/null
+++ b/math/qhull/pkg-descr
@@ -0,0 +1,12 @@
+ Qhull computes convex hulls, Delaunay triangulations, halfspace
+intersections about a point, Voronoi diagrams, furthest-site Delaunay
+triangulations, and furthest-site Voronoi diagrams. It runs in 2-d,
+3-d, 4-d, and higher dimensions. It implements the Quickhull algorithm
+for computing the convex hull. Qhull handles roundoff errors from
+floating point arithmetic. It computes volumes, surface areas, and
+approximations to the convex hull.
+
+WWW: www.qhull.org
+
+- Eduard
+pusto@web.de
diff --git a/math/qhull/pkg-plist b/math/qhull/pkg-plist
new file mode 100644
index 000000000000..ca983a89c1b9
--- /dev/null
+++ b/math/qhull/pkg-plist
@@ -0,0 +1,78 @@
+bin/qconvex
+bin/qdelaunay
+bin/qhalf
+bin/qhull
+bin/qvoronoi
+bin/rbox
+include/qhull/geom.h
+include/qhull/mem.h
+include/qhull/poly.h
+include/qhull/qhull_a.h
+include/qhull/stat.h
+include/qhull/io.h
+include/qhull/merge.h
+include/qhull/qhull.h
+include/qhull/qset.h
+include/qhull/user.h
+lib/libqhull.a
+lib/libqhull.so
+lib/libqhull.so.5
+@comment These doc files must be ditributed even with NOPORTDOCS
+%%DOCSDIR%%/Announce.txt
+%%DOCSDIR%%/COPYING.txt
+%%DOCSDIR%%/README.txt
+%%DOCSDIR%%/REGISTER.txt
+%%DOCSDIR%%/index.htm
+%%PORTDOCS%%%%DOCSDIR%%/Changes.txt
+%%PORTDOCS%%%%DOCSDIR%%/qh-geom.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-globa.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-io.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-mem.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-merge.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-poly.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-qhull.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-set.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-stat.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-user.htm
+%%PORTDOCS%%%%EXAMPLESDIR%%/user_eg.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/user_eg2.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/qhull_interface.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/Makefile.txt
+%%PORTDOCS%%%%EXAMPLESDIR%%/Mborland
+%%PORTDOCS%%%%EXAMPLESDIR%%/q_eg
+%%PORTDOCS%%%%EXAMPLESDIR%%/q_egtest
+%%PORTDOCS%%%%EXAMPLESDIR%%/q_test
+%%PORTDOCS%%%%EXAMPLESDIR%%/Qhull-go.bat
+%%PORTDOCS%%%%EXAMPLESDIR%%/q_test.bat
+%%PORTDOCS%%%%DOCSDIR%%/html/index.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/qconvex.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/qdelau_f.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/qdelaun.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/qh--4d.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/qh--cone.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/qh--dt.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/qh--geom.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/qh--half.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/qh--rand.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/qh-eg.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/qh-faq.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/qh-get.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/qh-impre.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/qh-in.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/qh-optc.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/qh-optf.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/qh-optg.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/qh-opto.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/qh-optp.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/qh-optq.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/qh-optt.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/qh-quick.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/qhalf.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/qhull.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/qvoron_f.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/qvoronoi.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/rbox.htm
+@dirrm include/qhull
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@dirrm %%DOCSDIR%%