aboutsummaryrefslogtreecommitdiff
path: root/math/qhull
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2016-12-12 02:46:23 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2016-12-12 02:46:23 +0000
commitbab9cd287716ea9bc1d58a46557cb1cc0006fe35 (patch)
tree2a7b843f0af4961fb245299613a0f604a6e8278e /math/qhull
parent4fa5c7bb4a4a0cac1e16a50ae6f6fa2e833c3ce6 (diff)
downloadports-bab9cd287716ea9bc1d58a46557cb1cc0006fe35.tar.gz
ports-bab9cd287716ea9bc1d58a46557cb1cc0006fe35.zip
- Add LICENCE, and small modification to description of error in
libqhullcpp_QhullSet.h. PR: ports/215078 Submitted by: z7dr6ut7gs@snkmail.com
Notes
Notes: svn path=/head/; revision=428392
Diffstat (limited to 'math/qhull')
-rw-r--r--math/qhull/Makefile5
-rw-r--r--math/qhull/files/patch-src_libqhullcpp_QhullSet.h4
2 files changed, 7 insertions, 2 deletions
diff --git a/math/qhull/Makefile b/math/qhull/Makefile
index dbc10854190e..022fe3522e5e 100644
--- a/math/qhull/Makefile
+++ b/math/qhull/Makefile
@@ -10,6 +10,11 @@ DISTNAME= ${PORTNAME}-2015-src-7.2.0
MAINTAINER= stephen@FreeBSD.org
COMMENT= Qhull computes convex hulls, Delaunay triangulations, and halfspaces
+LICENSE= Qhull
+LICENSE_NAME= Qhull License
+LICENSE_FILE= ${WRKSRC}/COPYING.txt
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
USES= cmake tar:tgz
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/math/qhull/files/patch-src_libqhullcpp_QhullSet.h b/math/qhull/files/patch-src_libqhullcpp_QhullSet.h
index d00f1089df51..4a4eacc17408 100644
--- a/math/qhull/files/patch-src_libqhullcpp_QhullSet.h
+++ b/math/qhull/files/patch-src_libqhullcpp_QhullSet.h
@@ -1,7 +1,7 @@
-c++ 4.2 (in base 9.x) gives a bogus error:
+c++ 4.2 (in base 9.x) has a weakness that emits a bogus error:
/usr/ports/math/qhull/work/qhull-2015.2/src/libqhullcpp/QhullSet.h:330: error: expected `;' before 'i'
- Work around that by removing overspecified part of type declaration.
+Work around that by removing overspecified part of type declaration (can remove after 9.x EOL).
--- src/libqhullcpp/QhullSet.h.orig 2016-01-18 19:45:12 UTC
+++ src/libqhullcpp/QhullSet.h