aboutsummaryrefslogtreecommitdiff
path: root/math/qtiplot
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2006-09-05 07:25:59 +0000
committerSimon Barner <barner@FreeBSD.org>2006-09-05 07:25:59 +0000
commit3bc7cc7a7aa5bb003c298ae79c3406f4f58db631 (patch)
tree377f6d1b7926b6201d4c1c6b9ae1a481c3137be8 /math/qtiplot
parentc404fba24f0bef1f86eb77d2cb479a119a1abea5 (diff)
downloadports-3bc7cc7a7aa5bb003c298ae79c3406f4f58db631.tar.gz
ports-3bc7cc7a7aa5bb003c298ae79c3406f4f58db631.zip
Notes
Diffstat (limited to 'math/qtiplot')
-rw-r--r--math/qtiplot/Makefile33
-rw-r--r--math/qtiplot/distinfo6
2 files changed, 24 insertions, 15 deletions
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index 2d9ab9c7cb4d..95ec35ed4ce0 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -6,16 +6,17 @@
#
PORTNAME= qtiplot
-PORTVERSION= 0.8.5
+PORTVERSION= 0.8.6.2
CATEGORIES= math science
MASTER_SITES= http://soft.proindependent.com/src/
+DISTNAME= ${PORTNAME}-0.8.6-2
MAINTAINER= makc@issp.ac.ru
COMMENT= An Origin clone for data analysis and scientific plotting
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl \
- qwt:${PORTSDIR}/x11-toolkits/qwt \
+ origin.0:${PORTSDIR}/math/liborigin \
qwtplot3d:${PORTSDIR}/math/qwtplot3d
USE_BZIP2= yes
@@ -33,33 +34,41 @@ MAKE_ENV= QTDIR=${QT_PREFIX}
IGNORE= does not compile on FreeBSD 4.x
.endif
-.if exists(${X11BASE}/share/qt/mkspecs/freebsd-g++)
-QMAKESPEC= ${X11BASE}/share/qt/mkspecs/freebsd-g++
-.else
+QMAKE= qmake
QMAKESPEC= ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
-.endif
+
+QPRO_DIRS= . \
+ 3rdparty/qwt \
+ fitPlugins/fitRational0 \
+ fitPlugins/fitRational1 \
+ qtiplot
post-patch:
+.for d in ${QPRO_DIRS}
@${REINPLACE_CMD} -e \
- "s:../3rdparty/qwt/include:${LOCALBASE}/include/qwt:" \
+ "s:../3rdparty/liborigin/include:${LOCALBASE}/include:" \
-e "s:/usr/include/qwtplot3d:${X11BASE}/include:" \
-e "/^unix:LIBS/s:-L /usr/lib:-L${LOCALBASE}/lib:" \
- -e "/^unix:LIBS/s:../3rdparty/qwt/lib/libqwt.a:-L ${LOCALBASE}/lib -lqwt:" \
-e "/^unix:documentation.path/s:/usr/share/doc/qtiplot:${DOCSDIR}:" \
- ${WRKSRC}/${PORTNAME}.pro
+ ${WRKSRC}/${d}/*.pro
+.endfor
do-configure:
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} qmake \
- -spec ${QMAKESPEC} ${PORTNAME}.pro
+.for d in ${QPRO_DIRS}
+ @cd ${WRKSRC}/${d} && ${SETENV} ${MAKE_ENV} ${QMAKE} \
+ -spec ${QMAKESPEC} *.pro
+.endfor
post-configure:
+.for d in ${QPRO_DIRS}
@${REINPLACE_CMD} -e \
's|^CC .*|CC=${CC}|; \
s|^CXX .*|CXX=${CXX}|; \
s|-pipe||; \
s|^\(CFLAGS .*= \)|\1${CFLAGS}|; \
s|^\(CXXFLAGS = \)|\1${CXXFLAGS}|' \
- ${WRKSRC}/Makefile
+ ${WRKSRC}/${d}/Makefile
+.endfor
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/qtiplot/qtiplot ${PREFIX}/bin
diff --git a/math/qtiplot/distinfo b/math/qtiplot/distinfo
index 45dc9c9ea4c6..dfa109ea4035 100644
--- a/math/qtiplot/distinfo
+++ b/math/qtiplot/distinfo
@@ -1,3 +1,3 @@
-MD5 (qtiplot-0.8.5.tar.bz2) = aa7350a3e5f2662077684421e0deb21f
-SHA256 (qtiplot-0.8.5.tar.bz2) = 81831d8dfaddbdf32d85a6e7eaf0e54e2321e2fba6ffaabfe6943bc326a6f874
-SIZE (qtiplot-0.8.5.tar.bz2) = 530579
+MD5 (qtiplot-0.8.6-2.tar.bz2) = 6025c050b291671ffcfcac7949e97c4e
+SHA256 (qtiplot-0.8.6-2.tar.bz2) = 64342a9c19ab7fff8dd1ea7e1dafe331709393a6ad892ffda8138ec07c3df657
+SIZE (qtiplot-0.8.6-2.tar.bz2) = 655993