aboutsummaryrefslogtreecommitdiff
path: root/math/reduce/Makefile
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2014-02-18 22:16:33 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2014-02-18 22:16:33 +0000
commitd405ab07b113ec63a9a58d1e78ee8e5e12b3c30c (patch)
tree59ded198633ff3ce9dfec5f5d8987a032dbabddd /math/reduce/Makefile
parent857e52fb19f384f861eabf086fce9bb825c7fa86 (diff)
downloadports-d405ab07b113ec63a9a58d1e78ee8e5e12b3c30c.tar.gz
ports-d405ab07b113ec63a9a58d1e78ee8e5e12b3c30c.zip
Notes
Diffstat (limited to 'math/reduce/Makefile')
-rw-r--r--math/reduce/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/math/reduce/Makefile b/math/reduce/Makefile
new file mode 100644
index 000000000000..f55264056c40
--- /dev/null
+++ b/math/reduce/Makefile
@@ -0,0 +1,55 @@
+# Created by: Pedro Giffuni
+# $FreeBSD$
+
+PORTNAME= reduce
+PORTVERSION= 20110414
+CATEGORIES= math lang
+MASTER_SITES= SF/${PORTNAME}-algebra/
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+
+MAINTAINER= giffunip@tutopia.com
+COMMENT= Portable general-purpose computer algebra system (CSL version)
+
+LICENSE= BSD
+
+RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff
+
+USE_BZIP2= yes
+USES= gmake
+USE_XORG= xext x11 xft
+USE_GNOME= lthack ltverhack
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --with-csl
+ALL_TARGET=
+
+.include <bsd.port.pre.mk>
+
+HMAN1= redcsl.1
+
+.if ${ARCH} == "amd64"
+TARGET_SDIR= x86_64-unknown-${OPSYS:L}${OSREL}
+.else
+TARGET_SDIR= ${ARCH}-unknown-${OPSYS:L}${OSREL}
+.endif
+REDUCECSL= ${WRKSRC}/cslbuild/${TARGET_SDIR}/csl
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_PROGRAM} ${REDUCECSL}/reduce ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${REDUCECSL}/reduce.img ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${FILESDIR}/runcsl.sh ${STAGEDIR}${PREFIX}/bin/redcsl
+ ${INSTALL_MAN} ${FILESDIR}/redcsl.1 ${STAGEDIR}${MANPREFIX}/man/man1/
+ ${MKDIR} ${STAGEDIR}${DATADIR}/reduce.doc
+ (cd ${REDUCECSL}/reduce.doc && ${COPYTREE_SHARE} . \
+ ${STAGEDIR}${DATADIR}/reduce.doc)
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${FONTDIR}
+ (cd ${REDUCECSL}/reduce.fonts && ${COPYTREE_SHARE} . \
+ ${STAGEDIR}${DATADIR}/reduce.fonts)
+
+.include <bsd.port.post.mk>