aboutsummaryrefslogtreecommitdiff
path: root/math/reed-solomon
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-19 09:34:58 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-19 09:34:58 +0000
commit965f4a98d67db79c6849d38edff1047387795a5c (patch)
tree310d823d6c585b15490368b13ffca85d43de84ff /math/reed-solomon
parent507ce4b5517ad936f6148240a23dfb4bbedc7f82 (diff)
downloadports-965f4a98d67db79c6849d38edff1047387795a5c.tar.gz
ports-965f4a98d67db79c6849d38edff1047387795a5c.zip
Stagify.
Approved by: portmgr@
Notes
Notes: svn path=/head/; revision=358369
Diffstat (limited to 'math/reed-solomon')
-rw-r--r--math/reed-solomon/Makefile3
-rw-r--r--math/reed-solomon/files/patch-makefile.in95
-rw-r--r--math/reed-solomon/pkg-plist1
3 files changed, 84 insertions, 15 deletions
diff --git a/math/reed-solomon/Makefile b/math/reed-solomon/Makefile
index 9e2f321554f5..77d914263ad3 100644
--- a/math/reed-solomon/Makefile
+++ b/math/reed-solomon/Makefile
@@ -14,9 +14,6 @@ USES= gmake
USE_LDCONFIG= yes
MAKEFILE= makefile
-MAN3= rs.3
-
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|gcc|${CC}|' ${WRKSRC}/makefile.in
diff --git a/math/reed-solomon/files/patch-makefile.in b/math/reed-solomon/files/patch-makefile.in
index 7fe4ab89894f..47608af59661 100644
--- a/math/reed-solomon/files/patch-makefile.in
+++ b/math/reed-solomon/files/patch-makefile.in
@@ -1,6 +1,6 @@
---- makefile.in.orig Wed Jun 29 16:52:23 2005
-+++ makefile.in Wed Jun 29 16:57:01 2005
-@@ -7,7 +7,7 @@
+--- makefile.in.orig 2002-02-13 10:27:56.000000000 +0800
++++ makefile.in 2014-06-19 17:31:43.462706589 +0800
+@@ -7,7 +7,7 @@ exec_prefix=@exec_prefix@
VPATH = @srcdir@
CC=@CC@
@@ -9,29 +9,100 @@
LIB= encode_rs_char.o encode_rs_int.o encode_rs_8.o \
decode_rs_char.o decode_rs_int.o decode_rs_8.o \
-@@ -24,20 +24,17 @@
- gcc -g -o $@ $^
+@@ -21,47 +21,44 @@ test: rstest
+
+ rstest: rstest.o exercise_int.o exercise_char.o exercise_8.o exercise_ccsds.o \
+ librs.a
+- gcc -g -o $@ $^
++ $(CC) -g -o $@ $^
install: all
- mkdir -p @libdir@
- install -D -m 644 -p librs.a librs.so.@SO_VERSION@ @libdir@
-+ $(BSD_INSTALL_DATA) librs.a @libdir@
-+ $(BSD_INSTALL_PROGRAM) librs.so.@SO_VERSION@ @libdir@
- (cd @libdir@;ln -f -s librs.so.@SO_VERSION@ librs.so)
+- (cd @libdir@;ln -f -s librs.so.@SO_VERSION@ librs.so)
- ldconfig
- mkdir -p @includedir@
- install -m 644 -p rs.h @includedir@
- mkdir -p @mandir@/man3
- install -m 644 rs.3 @mandir@/man3
-+ $(BSD_INSTALL_DATA) rs.h @includedir@
-+ $(BSD_INSTALL_MAN) rs.3 @mandir@/man3
++ $(BSD_INSTALL_DATA) librs.a $(DESTDIR)@libdir@
++ $(BSD_INSTALL_PROGRAM) librs.so.@SO_VERSION@ $(DESTDIR)@libdir@
++ ln -sf librs.so.@SO_VERSION@ $(DESTDIR)@libdir@/librs.so
++ $(BSD_INSTALL_DATA) rs.h $(DESTDIR)@includedir@
++ $(BSD_INSTALL_MAN) rs.3 $(DESTDIR)@mandir@/man3
librs.a: $(LIB)
ar rv $@ $^
librs.so.@SO_VERSION@: librs.a
- gcc -shared -Xlinker -soname=librs.so.@SO_NAME@ -o $@ -Wl,-whole-archive $^ -Wl,-no-whole-archive -lc
-+ gcc -shared -fPIC -Xlinker -soname=librs.so.@SO_NAME@ -o $@ -Wl,-whole-archive $^ -Wl,-no-whole-archive -lc
++ $(CC) -shared -fPIC -Xlinker -soname=librs.so.@SO_NAME@ -o $@ -Wl,-whole-archive $^ -Wl,-no-whole-archive -lc
encode_rs_char.o: encode_rs.c
- gcc $(CFLAGS) -c -o $@ $^
+- gcc $(CFLAGS) -c -o $@ $^
++ $(CC) $(CFLAGS) -c -o $@ $^
+
+ encode_rs_int.o: encode_rs.c
+- gcc -DBIGSYM=1 $(CFLAGS) -c -o $@ $^
++ $(CC) -DBIGSYM=1 $(CFLAGS) -c -o $@ $^
+
+ encode_rs_8.o: encode_rs.c
+- gcc -DFIXED=1 $(CFLAGS) -c -o $@ $^
++ $(CC) -DFIXED=1 $(CFLAGS) -c -o $@ $^
+
+ decode_rs_char.o: decode_rs.c
+- gcc $(CFLAGS) -c -o $@ $^
++ $(CC) $(CFLAGS) -c -o $@ $^
+
+ decode_rs_int.o: decode_rs.c
+- gcc -DBIGSYM=1 $(CFLAGS) -c -o $@ $^
++ $(CC) -DBIGSYM=1 $(CFLAGS) -c -o $@ $^
+
+ decode_rs_8.o: decode_rs.c
+- gcc -DFIXED=1 $(CFLAGS) -c -o $@ $^
++ $(CC) -DFIXED=1 $(CFLAGS) -c -o $@ $^
+
+ init_rs_char.o: init_rs.c
+- gcc $(CFLAGS) -c -o $@ $^
++ $(CC) $(CFLAGS) -c -o $@ $^
+
+ init_rs_int.o: init_rs.c
+- gcc -DBIGSYM=1 $(CFLAGS) -c -o $@ $^
++ $(CC) -DBIGSYM=1 $(CFLAGS) -c -o $@ $^
+
+ ccsds_tab.o: ccsds_tab.c
+
+@@ -69,10 +66,10 @@ ccsds_tab.c: gen_ccsds
+ ./gen_ccsds > ccsds_tab.c
+
+ gen_ccsds: gen_ccsds.o init_rs_char.o
+- gcc -o $@ $^
++ $(CC) -o $@ $^
+
+ gen_ccsds.o: gen_ccsds.c
+- gcc $(CFLAGS) -c -o $@ $^
++ $(CC) $(CFLAGS) -c -o $@ $^
+
+ ccsds_tal.o: ccsds_tal.c
+
+@@ -80,16 +77,16 @@ ccsds_tal.c: gen_ccsds_tal
+ ./gen_ccsds_tal > ccsds_tal.c
+
+ exercise_char.o: exercise.c
+- gcc $(CFLAGS) -c -o $@ $^
++ $(CC) $(CFLAGS) -c -o $@ $^
+
+ exercise_int.o: exercise.c
+- gcc -DBIGSYM=1 $(CFLAGS) -c -o $@ $^
++ $(CC) -DBIGSYM=1 $(CFLAGS) -c -o $@ $^
+
+ exercise_8.o: exercise.c
+- gcc -DFIXED=1 $(CFLAGS) -c -o $@ $^
++ $(CC) -DFIXED=1 $(CFLAGS) -c -o $@ $^
+
+ exercise_ccsds.o: exercise.c
+- gcc -DCCSDS=1 $(CFLAGS) -c -o $@ $^
++ $(CC) -DCCSDS=1 $(CFLAGS) -c -o $@ $^
+
+
+ clean:
diff --git a/math/reed-solomon/pkg-plist b/math/reed-solomon/pkg-plist
index ce0438ddb48d..21d438f24de4 100644
--- a/math/reed-solomon/pkg-plist
+++ b/math/reed-solomon/pkg-plist
@@ -2,3 +2,4 @@ include/rs.h
lib/librs.a
lib/librs.so
lib/librs.so.4.0.0
+man/man3/rs.3.gz