aboutsummaryrefslogtreecommitdiff
path: root/math/rubygem-matrix
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-05-16 10:50:02 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-05-16 10:50:02 +0000
commit710eb39081814b91430dda0a7561948bc96c2c15 (patch)
treec105871450e9dbecb85e432e58ec9307442390bd /math/rubygem-matrix
parent2f210f113e03924192f1e10c0aa60613d48eef46 (diff)
downloadports-710eb39081814b91430dda0a7561948bc96c2c15.tar.gz
ports-710eb39081814b91430dda0a7561948bc96c2c15.zip
Add rubygem-matrix 0.3.0
Matrix is an implementation of Matrix and Vector classes. The Matrix class represents a mathematical matrix. It provides methods for creating matrices, operating on them arithmetically and algebraically, and determining their mathematical properties (trace, rank, inverse, determinant, eigensystem, etc.). The Vector class represents a mathematical vector, which is useful in its own right, and also constitutes a row or column of a Matrix. WWW: https://github.com/ruby/matrix
Notes
Notes: svn path=/head/; revision=535386
Diffstat (limited to 'math/rubygem-matrix')
-rw-r--r--math/rubygem-matrix/Makefile20
-rw-r--r--math/rubygem-matrix/distinfo3
-rw-r--r--math/rubygem-matrix/pkg-descr11
3 files changed, 34 insertions, 0 deletions
diff --git a/math/rubygem-matrix/Makefile b/math/rubygem-matrix/Makefile
new file mode 100644
index 000000000000..92ee397248e6
--- /dev/null
+++ b/math/rubygem-matrix/Makefile
@@ -0,0 +1,20 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= matrix
+PORTVERSION= 0.3.0
+CATEGORIES= math rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Implementation of Matrix and Vector classes
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/rubygem-matrix/distinfo b/math/rubygem-matrix/distinfo
new file mode 100644
index 000000000000..66dc664dcea6
--- /dev/null
+++ b/math/rubygem-matrix/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1588336471
+SHA256 (rubygem/matrix-0.3.0.gem) = 3df4ddb8c5ef22bb4e883dbbbd860eec309788297df29a825734e8e52ad729a0
+SIZE (rubygem/matrix-0.3.0.gem) = 28160
diff --git a/math/rubygem-matrix/pkg-descr b/math/rubygem-matrix/pkg-descr
new file mode 100644
index 000000000000..d3b65acddcd4
--- /dev/null
+++ b/math/rubygem-matrix/pkg-descr
@@ -0,0 +1,11 @@
+Matrix is an implementation of Matrix and Vector classes.
+
+The Matrix class represents a mathematical matrix. It provides methods for
+creating matrices, operating on them arithmetically and algebraically, and
+determining their mathematical properties (trace, rank, inverse, determinant,
+eigensystem, etc.).
+
+The Vector class represents a mathematical vector, which is useful in its own
+right, and also constitutes a row or column of a Matrix.
+
+WWW: https://github.com/ruby/matrix