aboutsummaryrefslogtreecommitdiff
path: root/math/saga/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2018-06-17 22:56:19 +0000
committerWen Heping <wen@FreeBSD.org>2018-06-17 22:56:19 +0000
commit49baed99df92d216ed6c6a8c7a8896a8a9ebabf4 (patch)
tree2d755fbd36869f14ffdfb2519fae6ea15b6436b6 /math/saga/Makefile
parent387268bb4a72fdaf6b78d66cee3b897ffe2c8f7f (diff)
downloadports-49baed99df92d216ed6c6a8c7a8896a8a9ebabf4.tar.gz
ports-49baed99df92d216ed6c6a8c7a8896a8a9ebabf4.zip
- Update version from 6.1.0 to 6.3.0
- Use devel/liblas12 with changed naming scheme - If using openMP, change the compiler from gcc to clang - Recreate some patches with makepatch PR: 227901 Submitted by: rhurlin@gwdg.de(maintainer)
Notes
Notes: svn path=/head/; revision=472649
Diffstat (limited to 'math/saga/Makefile')
-rw-r--r--math/saga/Makefile32
1 files changed, 21 insertions, 11 deletions
diff --git a/math/saga/Makefile b/math/saga/Makefile
index f22186960c8c..03c61d9f3d93 100644
--- a/math/saga/Makefile
+++ b/math/saga/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= saga
-PORTVERSION= 6.1.0
-PORTREVISION= 4
+PORTVERSION= 6.3.0
CATEGORIES= math
MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]\.[[:digit:]]*$//}/SAGA%20-%20${PORTVERSION}
@@ -13,12 +12,13 @@ COMMENT= System for Automated Geoscientific Analyses
LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
-BUILD_DEPENDS= swig3.0:devel/swig30
+BUILD_DEPENDS= clang50:devel/llvm50 \
+ swig3.0:devel/swig30
LIB_DEPENDS= libfftw3.so:math/fftw3 \
libgdal.so:graphics/gdal \
libhpdf.so:print/libharu \
libjasper.so:graphics/jasper \
- liblas.so:devel/liblas12 \
+ liblas12.so:devel/liblas12 \
libodbc.so:databases/unixODBC \
libopencv_core.so:graphics/opencv-core \
libopencv_ml.so:graphics/opencv \
@@ -26,12 +26,11 @@ LIB_DEPENDS= libfftw3.so:math/fftw3 \
libsvm.so:science/libsvm \
libtbb.so:devel/tbb \
libtiff.so:graphics/tiff
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS:= swig3.0:devel/swig30
-USES= autoreconf compiler:gcc-c++11-lib desktop-file-utils dos2unix \
+USES= autoreconf compiler:c++11-lib desktop-file-utils dos2unix \
iconv:wchar_t libtool localbase pkgconfig python:2.7
USE_LDCONFIG= yes
-USE_CXXSTD= c++11
USE_WX= 3.0+
CONFIGURE_ARGS= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
--enable-python --with-system-svm
@@ -39,19 +38,27 @@ CONFIGURE_ENV= SWIG="${LOCALBASE}/bin/swig3.0"
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+CPP= clang-cpp50
+CC= clang50
+CXX= clang++50
INSTALLS_ICONS= yes
DOS2UNIX_GLOB= *.cpp *.h
PLIST_SUB= PORTVERSION=${PORTVERSION}
OPTIONS_DEFINE= PGSQL OPENMP VIGRA
-OPTIONS_DEFAULT= PGSQL OPENMP VIGRA
+OPTIONS_DEFAULT= PGSQL VIGRA
+OPTIONS_DEFAULT_amd64= OPENMP
+OPTIONS_DEFAULT_i386= OPENMP
NO_OPTIONS_SORT= yes
OPTIONS_SUB= yes
-OPENMP_DESC= Enable Multiprocessing
+OPENMP_DESC= Enable Multiprocessing (only amd64 and i386)
VIGRA_DESC= Enable 'Vision with Generic Algorithms' Library
+## TODO: OPENMP_?= Only for archs amd64 and i386
OPENMP_CONFIGURE_ENABLE= openmp
-OPENMP_LDFLAGS= -pthread
+OPENMP_LIB_DEPENDS= libomp.so:devel/openmp
+OPENMP_LDFLAGS= -L${LOCALBASE}/lib -lm -pthread
+#OPENMP_EXTRA_PATCHES= ${PATCHDIR}/
PGSQL_CONFIGURE_OFF= --with-postgresql=no
PGSQL_CONFIGURE_ON= --with-postgresql=${LOCALBASE}/bin/pg_config
PGSQL_USES= pgsql
@@ -91,10 +98,13 @@ post-patch:
@${REINPLACE_CMD} -e 's|PORTVERSION|${PORTVERSION}|' \
${WRKSRC}/src/saga_core/saga_gui/dlg_about.cpp
+post-patch-OPENMP-on:
+ @${REINPLACE_CMD} -e 's|-lgomp|-lomp|' ${WRKSRC}/configure.ac
+
post-configure:
@${REINPLACE_CMD} -e 's|cd $$(pkgdatadir);|cd ${STAGEDIR}${DATADIR};|g' \
${WRKSRC}/src/saga_core/saga_gui/Makefile
- @${REINPLACE_CMD} -e 's|^LDFLAGS = .*|& -lopencv_contrib|' \
+ @${REINPLACE_CMD} -e 's|^LDFLAGS = .*|& -lopencv_core|' \
${WRKSRC}/src/tools/imagery/imagery_opencv/Makefile
post-install: