aboutsummaryrefslogtreecommitdiff
path: root/math/saga
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2019-06-27 03:37:10 +0000
committerWen Heping <wen@FreeBSD.org>2019-06-27 03:37:10 +0000
commit3d23ba68ab99fb4d59e9795ce691e40be3d48c8b (patch)
tree9d7639e045bd1b558843fd036fa2fa9922c9400b /math/saga
parent81f468837bda92e07f4bb7b261840c87179d2aaa (diff)
downloadports-3d23ba68ab99fb4d59e9795ce691e40be3d48c8b.tar.gz
ports-3d23ba68ab99fb4d59e9795ce691e40be3d48c8b.zip
- Update to 6.1.0 and fix some ports
- Add missing DEPENDS - Add TEST_TARGET - Take maintainership PR: 237932, 238795 Submitted by: wenheping2000@hotmail.com,rhurlin@gwdg.de Approved by: maintainer(timeout, > 30 days), portmgr@(implicit, fix build) Exp-run by: antoine@ Thanks to: antoine@, sunpoet@, rhurlin@gwdg.de
Notes
Notes: svn path=/head/; revision=505194
Diffstat (limited to 'math/saga')
-rw-r--r--math/saga/Makefile17
-rw-r--r--math/saga/distinfo6
-rw-r--r--math/saga/files/patch-configure.ac9
-rw-r--r--math/saga/files/patch-src_tools_io_io__shapes__las_las__export.cpp9
-rw-r--r--math/saga/files/patch-src_tools_io_io__shapes__las_las__import.cpp8
-rw-r--r--math/saga/files/patch-src_tools_io_io__shapes__las_las__info.h8
-rw-r--r--math/saga/pkg-plist5
7 files changed, 33 insertions, 29 deletions
diff --git a/math/saga/Makefile b/math/saga/Makefile
index b2798e6f1111..6187e089d092 100644
--- a/math/saga/Makefile
+++ b/math/saga/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= saga
-PORTVERSION= 7.2.0
+PORTVERSION= 7.3.0
CATEGORIES= math
MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]\.[[:digit:]]*$//}/SAGA%20-%20${PORTVERSION}
@@ -12,7 +12,7 @@ COMMENT= System for Automated Geoscientific Analyses
LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
-BUILD_DEPENDS= clang70:devel/llvm70 \
+BUILD_DEPENDS= clang${LLVM_VER}:devel/llvm${LLVM_VER} \
swig3.0:devel/swig30
LIB_DEPENDS= libcurl.so:ftp/curl \
libfftw3.so:math/fftw3 \
@@ -30,7 +30,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
RUN_DEPENDS:= swig3.0:devel/swig30
USES= autoreconf compiler:c++11-lib desktop-file-utils dos2unix \
- iconv:wchar_t libtool localbase pkgconfig python:2.7
+ iconv:wchar_t libtool localbase pkgconfig python
USE_LDCONFIG= yes
USE_WX= 3.0+
@@ -56,8 +56,8 @@ VIGRA_DESC= Enable 'Vision with Generic Algorithms' Library
OPENMP_CONFIGURE_ENABLE= openmp
OPENMP_LDFLAGS= -L${LOCALBASE}/lib -lm
-# Use OpenMP from lang/llvm70
-OPENMP_LDFLAGS+= -L${LOCALBASE}/llvm70/lib -lomp
+# Use OpenMP from lang/llvm${LLVM_VER}
+OPENMP_LDFLAGS+= -L${LOCALBASE}/llvm${LLVM_VER}/lib -lomp
PGSQL_CONFIGURE_OFF= --with-postgresql=no
PGSQL_CONFIGURE_ON= --with-postgresql=${LOCALBASE}/bin/pg_config
PGSQL_USES= pgsql
@@ -69,9 +69,10 @@ INSTALL_TARGET= install-strip
.include <bsd.port.pre.mk>
# make describe needs them here
-CPP= clang-cpp70
-CC= clang70
-CXX= clang++70
+LLVM_VER= 80
+CPP= clang-cpp${LLVM_VER}
+CC= clang${LLVM_VER}
+CXX= clang++${LLVM_VER}
SUB_FILES= pkg-message
diff --git a/math/saga/distinfo b/math/saga/distinfo
index dfcd593984b8..52fa4c13db84 100644
--- a/math/saga/distinfo
+++ b/math/saga/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1550398605
-SHA256 (saga-7.2.0.tar.gz) = 56152aa39e90e60fb8bcd2b9ded30706176d3a7f50084505138fcfc26a61f281
-SIZE (saga-7.2.0.tar.gz) = 4676920
+TIMESTAMP = 1561394217
+SHA256 (saga-7.3.0.tar.gz) = f3c0f805bd48c3afbad56a35b6b0aa40e8e92799ed0ef0d682aea275fa36fbbc
+SIZE (saga-7.3.0.tar.gz) = 4742356
diff --git a/math/saga/files/patch-configure.ac b/math/saga/files/patch-configure.ac
index 56a5a7c9fd05..a356794aa747 100644
--- a/math/saga/files/patch-configure.ac
+++ b/math/saga/files/patch-configure.ac
@@ -1,6 +1,6 @@
---- configure.ac.orig 2018-11-22 07:53:05 UTC
+--- configure.ac.orig 2019-04-09 17:14:15 UTC
+++ configure.ac
-@@ -20,13 +20,13 @@ AC_PROG_LIBTOOL
+@@ -20,7 +20,7 @@ AC_PROG_LIBTOOL
AC_CHECK_LIB([opencv_core], [cvGetRows], CVFOUND=1,,)
AC_CHECK_LIB([geotrans], [Set_Mercator_Coordinates])
AC_CHECK_LIB([fftw3],[fftw_execute],FFTWFOUND=1,)
@@ -8,7 +8,10 @@
+AC_CHECK_LIB([las12], [LAS_GetVersion], LASFOUND=1,,)
AC_CHECK_LIB(hpdf, HPDF_Pages_New, HARUFOUND=1,,)
AC_CHECK_LIB([odbc], [SQLFetch], ODBCFOUND=1,[ODBC \(libodbc\) library not found])
- AC_CHECK_LIB([proj], [pj_is_latlong], PROJFOUND=1,,)
+ # PROJ4 has projects.h and old API function:
+@@ -30,8 +30,8 @@ AC_CHECK_HEADER([projects.h],[AC_CHECK_HEADER([proj.h]
+ # PROJ6 has dropped projects.h in favour of proj.h and has new API function:
+ AC_CHECK_HEADER([proj.h],[AC_CHECK_LIB([proj], [proj_info], PROJ6FOUND=1,,)])
AC_CHECK_LIB([vigraimpex], [VIGRA_RGBE_ReadPixels_Raw],VIGRAFOUND=1,)
-AC_CHECK_LIB([gomp], [omp_get_num_threads], GOMPFOUND=1,,)
-AC_CHECK_HEADER([libsvm/svm.h],[AC_CHECK_LIB([svm], [svm_get_svm_type], SVMFOUND=1,,)])
diff --git a/math/saga/files/patch-src_tools_io_io__shapes__las_las__export.cpp b/math/saga/files/patch-src_tools_io_io__shapes__las_las__export.cpp
index 683632ff3293..0996946f65bf 100644
--- a/math/saga/files/patch-src_tools_io_io__shapes__las_las__export.cpp
+++ b/math/saga/files/patch-src_tools_io_io__shapes__las_las__export.cpp
@@ -1,9 +1,9 @@
---- src/tools/io/io_shapes_las/las_export.cpp.orig 2018-06-19 12:39:11 UTC
+--- src/tools/io/io_shapes_las/las_export.cpp.orig 2019-06-24 16:41:27 UTC
+++ src/tools/io/io_shapes_las/las_export.cpp
-@@ -61,9 +61,9 @@
- //---------------------------------------------------------
- #include "las_export.h"
+@@ -59,9 +59,9 @@
+ ///////////////////////////////////////////////////////////
+ //---------------------------------------------------------
-#include <liblas/laspoint.hpp>
-#include <liblas/laswriter.hpp>
-#include <liblas/capi/las_version.h>
@@ -13,4 +13,3 @@
#include <fstream>
#include <iostream>
#include <cstddef>
-
diff --git a/math/saga/files/patch-src_tools_io_io__shapes__las_las__import.cpp b/math/saga/files/patch-src_tools_io_io__shapes__las_las__import.cpp
index f8b5d812a60c..13ef2b014a29 100644
--- a/math/saga/files/patch-src_tools_io_io__shapes__las_las__import.cpp
+++ b/math/saga/files/patch-src_tools_io_io__shapes__las_las__import.cpp
@@ -1,9 +1,9 @@
---- src/tools/io/io_shapes_las/las_import.cpp.orig 2018-05-01 09:07:10 UTC
+--- src/tools/io/io_shapes_las/las_import.cpp.orig 2019-06-24 16:44:36 UTC
+++ src/tools/io/io_shapes_las/las_import.cpp
-@@ -60,9 +60,9 @@
- //---------------------------------------------------------
- #include "las_import.h"
+@@ -58,9 +58,9 @@
+ ///////////////////////////////////////////////////////////
+ //---------------------------------------------------------
-#include <liblas/laspoint.hpp>
-#include <liblas/lasreader.hpp>
-#include <liblas/capi/las_version.h>
diff --git a/math/saga/files/patch-src_tools_io_io__shapes__las_las__info.h b/math/saga/files/patch-src_tools_io_io__shapes__las_las__info.h
index 1cad8c48fc8c..f89957d17365 100644
--- a/math/saga/files/patch-src_tools_io_io__shapes__las_las__info.h
+++ b/math/saga/files/patch-src_tools_io_io__shapes__las_las__info.h
@@ -1,9 +1,9 @@
---- src/tools/io/io_shapes_las/las_info.h.orig 2018-05-01 09:07:11 UTC
+--- src/tools/io/io_shapes_las/las_info.h.orig 2019-06-24 16:47:07 UTC
+++ src/tools/io/io_shapes_las/las_info.h
-@@ -76,9 +76,9 @@
- //---------------------------------------------------------
- #include "MLB_Interface.h"
+@@ -74,9 +74,9 @@
+ ///////////////////////////////////////////////////////////
+ //---------------------------------------------------------
-#include <liblas/laspoint.hpp>
-#include <liblas/lasreader.hpp>
-#include <liblas/capi/las_version.h>
diff --git a/math/saga/pkg-plist b/math/saga/pkg-plist
index ad4444ac1059..ca4166cb6c20 100644
--- a/math/saga/pkg-plist
+++ b/math/saga/pkg-plist
@@ -31,12 +31,12 @@ lib/libsaga_api-%%PORTVERSION%%.so
lib/libsaga_api.so
lib/libsaga_gdi-%%PORTVERSION%%.so
lib/libsaga_gdi.so
+%%PYTHON_SITELIBDIR%%/__pycache__/saga_api.cpython-36.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/__pycache__/saga_api.cpython-36.pyc
%%PYTHON_SITELIBDIR%%/_saga_api-%%PORTVERSION%%.so
%%PYTHON_SITELIBDIR%%/_saga_api.a
%%PYTHON_SITELIBDIR%%/_saga_api.so
%%PYTHON_SITELIBDIR%%/saga_api.py
-%%PYTHON_SITELIBDIR%%/saga_api.pyc
-%%PYTHON_SITELIBDIR%%/saga_api.pyo
lib/saga/libclimate_tools.so
lib/saga/libcontrib_perego.so
lib/saga/libdb_odbc.so
@@ -210,6 +210,7 @@ share/pixmaps/saga.png
%%DATADIR%%/toolchains/polygons_remove_from_boundary.xml
%%DATADIR%%/toolchains/shapes_select_delete.xml
%%DATADIR%%/toolchains/sieve_and_clump.xml
+%%DATADIR%%/toolchains/ta_flow_accumulation.xml
%%DATADIR%%/toolchains/ta_summits.xml
%%DATADIR%%/toolchains/temperature_downscaling.xml
%%DATADIR%%/toolchains/temperature_downscaling_bulk.xml