aboutsummaryrefslogtreecommitdiff
path: root/math/saga
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-08-29 16:56:00 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-08-29 16:56:00 +0000
commit840978d42ec1f8528503eed8b7c07fa9c2d5c050 (patch)
tree23d6c60d73bfc0cad1f556cf3dcee2dcb03b0b9d /math/saga
parent6b070bbfa66685d944d87cec38d590239738278a (diff)
downloadports-840978d42ec1f8528503eed8b7c07fa9c2d5c050.tar.gz
ports-840978d42ec1f8528503eed8b7c07fa9c2d5c050.zip
math/saga: Update to 7.7.0
Notes
Notes: svn path=/head/; revision=546925
Diffstat (limited to 'math/saga')
-rw-r--r--math/saga/Makefile4
-rw-r--r--math/saga/distinfo6
-rw-r--r--math/saga/files/patch-src_saga__core_saga__gui_dlg__about.cpp69
-rw-r--r--math/saga/files/patch-src_tools_imagery_imagery__opencv_opencv.h12
-rw-r--r--math/saga/files/patch-src_tools_projection_pj__proj4_globe__gores.cpp11
-rw-r--r--math/saga/pkg-plist7
6 files changed, 75 insertions, 34 deletions
diff --git a/math/saga/Makefile b/math/saga/Makefile
index 83404cacc923..a1c75db9c20d 100644
--- a/math/saga/Makefile
+++ b/math/saga/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= saga
-PORTVERSION= 7.6.3
-PORTREVISION= 2
+PORTVERSION= 7.7.0
CATEGORIES= math
MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]\.[[:digit:]]*$//}/SAGA%20-%20${PORTVERSION}
@@ -119,7 +118,6 @@ post-install:
# toolchains dir was moved in r2805 (and followups r2810,r2811,r2820)
(cd ${WRKSRC}/src/accessories && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
${RM} -R ${STAGEDIR}${DATADIR}/CMakeLists.txt
- ${RM} -R ${STAGEDIR}${DATADIR}/accessories/toolchains
${RM} -R ${STAGEDIR}${DATADIR}/templates/template4saga-tools/my_tool_library/Makefile.bak
${INSTALL_DATA} ${WRKSRC}/src/saga_core/saga_gui/res/saga.desktop \
${STAGEDIR}${PREFIX}/share/applications/
diff --git a/math/saga/distinfo b/math/saga/distinfo
index 4043ffcfce51..af4e66692cef 100644
--- a/math/saga/distinfo
+++ b/math/saga/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1589116009
-SHA256 (saga-7.6.3.tar.gz) = 8b791ca26e3e2ab923e6661b60fd5f57f5707ada7315028f4fed2591bcf03838
-SIZE (saga-7.6.3.tar.gz) = 5034062
+TIMESTAMP = 1598374828
+SHA256 (saga-7.7.0.tar.gz) = f327cf8502cb4850e921985b8c3d6aa97adb7c1c612b7b935657547619cdbbda
+SIZE (saga-7.7.0.tar.gz) = 5083931
diff --git a/math/saga/files/patch-src_saga__core_saga__gui_dlg__about.cpp b/math/saga/files/patch-src_saga__core_saga__gui_dlg__about.cpp
index 1d49253ed082..2d85097d5851 100644
--- a/math/saga/files/patch-src_saga__core_saga__gui_dlg__about.cpp
+++ b/math/saga/files/patch-src_saga__core_saga__gui_dlg__about.cpp
@@ -1,6 +1,6 @@
---- src/saga_core/saga_gui/dlg_about.cpp.orig 2018-11-22 07:53:06 UTC
+--- src/saga_core/saga_gui/dlg_about.cpp.orig 2020-08-25 19:21:15 UTC
+++ src/saga_core/saga_gui/dlg_about.cpp
-@@ -188,6 +188,7 @@ wxString CDLG_About::_Get_Version(void)
+@@ -177,6 +177,7 @@ wxString CDLG_About::_Get_Version(void)
s += "http://www.saga-gis.org\n";
s += "\n";
s += "Version: " + wxString(SAGA_VERSION) + "\n";
@@ -8,12 +8,73 @@
#ifdef _SAGA_MSW
#ifdef _WIN64
-@@ -263,7 +264,47 @@ wxString CDLG_About::_Get_Version(void)
+@@ -254,13 +255,107 @@ wxString CDLG_About::_Get_Version(void)
+ #elif defined(__PGI)
+ "Portland PGCC/PGCPP"
+ #elif defined(__clang__)
+- "Clang/LLVM"
++ #if (__clang_major__ == 11 && __clang_minor__ == 0 && __clang_patchlevel__ == 1)
++ "Clang/LLVM 11.0.1"
++ #elif (__clang_major__ == 11 && __clang_minor__ == 0 && __clang_patchlevel__ == 0)
++ "Clang/LLVM 11.0.0"
++ #elif (__clang_major__ == 10 && __clang_minor__ == 0 && __clang_patchlevel__ == 1)
++ "Clang/LLVM 10.0.1"
++ #elif (__clang_major__ == 10 && __clang_minor__ == 0 && __clang_patchlevel__ == 0)
++ "Clang/LLVM 10.0.0"
++ #elif (__clang_major__ == 9 && __clang_minor__ == 0 && __clang_patchlevel__ == 1)
++ "Clang/LLVM 9.0.1"
++ #elif (__clang_major__ == 9 && __clang_minor__ == 0 && __clang_patchlevel__ == 0)
++ "Clang/LLVM 9.0.0"
++ #elif (__clang_major__ == 8 && __clang_minor__ == 0 && __clang_patchlevel__ == 1)
++ "Clang/LLVM 8.0.1"
++ #elif (__clang_major__ == 8 && __clang_minor__ == 0 && __clang_patchlevel__ == 0)
++ "Clang/LLVM 8.0.0"
++ #elif (__clang_major__ == 7 && __clang_minor__ == 0 && __clang_patchlevel__ == 1)
++ "Clang/LLVM 7.0.1"
++ #elif (__clang_major__ == 7 && __clang_minor__ == 0 && __clang_patchlevel__ == 0)
++ "Clang/LLVM 7.0.0"
++ #elif (__clang_major__ == 6 && __clang_minor__ == 0 && __clang_patchlevel__ == 1)
++ "Clang/LLVM 6.0.1"
++ #elif (__clang_major__ == 6 && __clang_minor__ == 0 && __clang_patchlevel__ == 0)
++ "Clang/LLVM 6.0.0"
++ #else
++ "Clang/LLVM"
++ #endif
+ #elif defined(__MINGW32__)
+ "MinGW"
#elif defined(__GNUWIN32__)
"Gnu-Win32 compiler"
#elif defined(__GNUG__)
- "Gnu C++"
-+ #if wxCHECK_GCC_VERSION(6,4)
++ #if wxCHECK_GCC_VERSION(9,4)
++ "Gnu C++ 9.4"
++ #elif wxCHECK_GCC_VERSION(9,3)
++ "Gnu C++ 9.3"
++ #elif wxCHECK_GCC_VERSION(9,2)
++ "Gnu C++ 9.2"
++ #elif wxCHECK_GCC_VERSION(9,1)
++ "Gnu C++ 9.1"
++ #elif wxCHECK_GCC_VERSION(9,0)
++ "Gnu C++ 9.0"
++ #elif wxCHECK_GCC_VERSION(8,3)
++ "Gnu C++ 8.3"
++ #elif wxCHECK_GCC_VERSION(8,2)
++ "Gnu C++ 8.2"
++ #elif wxCHECK_GCC_VERSION(8,1)
++ "Gnu C++ 8.1"
++ #elif wxCHECK_GCC_VERSION(8,0)
++ "Gnu C++ 8.0"
++ #elif wxCHECK_GCC_VERSION(7,4)
++ "Gnu C++ 7.4"
++ #elif wxCHECK_GCC_VERSION(7,3)
++ "Gnu C++ 7.3"
++ #elif wxCHECK_GCC_VERSION(7,2)
++ "Gnu C++ 7.2"
++ #elif wxCHECK_GCC_VERSION(7,1)
++ "Gnu C++ 7.1"
++ #elif wxCHECK_GCC_VERSION(7,0)
++ "Gnu C++ 7.0"
++ #elif wxCHECK_GCC_VERSION(6,4)
+ "Gnu C++ 6.4"
+ #elif wxCHECK_GCC_VERSION(6,3)
+ "Gnu C++ 6.3"
diff --git a/math/saga/files/patch-src_tools_imagery_imagery__opencv_opencv.h b/math/saga/files/patch-src_tools_imagery_imagery__opencv_opencv.h
deleted file mode 100644
index 744635146411..000000000000
--- a/math/saga/files/patch-src_tools_imagery_imagery__opencv_opencv.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/tools/imagery/imagery_opencv/opencv.h.orig 2018-11-22 07:53:06 UTC
-+++ src/tools/imagery/imagery_opencv/opencv.h
-@@ -73,7 +73,8 @@
-
- //---------------------------------------------------------
- #include <opencv/cv.h>
--
-+#include <opencv2/core/core_c.h>
-+#include <opencv2/imgproc/imgproc_c.h>
-
- ///////////////////////////////////////////////////////////
- // //
diff --git a/math/saga/files/patch-src_tools_projection_pj__proj4_globe__gores.cpp b/math/saga/files/patch-src_tools_projection_pj__proj4_globe__gores.cpp
deleted file mode 100644
index 2b3a3a970083..000000000000
--- a/math/saga/files/patch-src_tools_projection_pj__proj4_globe__gores.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/tools/projection/pj_proj4/globe_gores.cpp.orig 2020-05-24 11:21:37 UTC
-+++ src/tools/projection/pj_proj4/globe_gores.cpp
-@@ -207,7 +207,7 @@ bool CGlobe_Gores::Add_Gore(int iGore, int nGores)
-
- SG_Get_Tool_Library_Manager().Delete_Tool(pTool);
-
-- return( NULL );
-+ return( false );
- }
-
- CSG_Grid *pGore = pTool->Get_Parameter("GRID")->asGrid();
diff --git a/math/saga/pkg-plist b/math/saga/pkg-plist
index 1f458f74265f..5ffbb75ba10c 100644
--- a/math/saga/pkg-plist
+++ b/math/saga/pkg-plist
@@ -86,6 +86,7 @@ lib/saga/libshapes_points.so
lib/saga/libshapes_polygons.so
lib/saga/libshapes_tools.so
lib/saga/libshapes_transect.so
+lib/saga/libsim_air_flow.so
lib/saga/libsim_cellular_automata.so
lib/saga/libsim_ecosystems_hugget.so
lib/saga/libsim_erosion.so
@@ -182,9 +183,11 @@ share/pixmaps/saga.png
%%DATADIR%%/templates/template4saga-tools/my_tool_library/my_tool.h
%%DATADIR%%/templates/template4saga-tools/my_tool_library/my_tool_library.cbp
%%DATADIR%%/templates/template4saga-tools/my_tool_library/my_tool_library.layout
+%%DATADIR%%/templates/template4saga-tools/my_tool_library/my_tool_library.vcxproj
+%%DATADIR%%/templates/template4saga-tools/my_tool_library/my_tool_library.vcxproj.filters
%%DATADIR%%/templates/template4saga-tools/my_tools.vc14.sln
%%DATADIR%%/templates/template4saga-tools/readme.txt
-%%DATADIR%%/toolchains/climate.xml
+%%DATADIR%%/toolchains/climate_tools.xml
%%DATADIR%%/toolchains/cluster_terrain.xml
%%DATADIR%%/toolchains/gc_filter_gaussian.xml
%%DATADIR%%/toolchains/gc_filter_laplacian.xml
@@ -192,10 +195,12 @@ share/pixmaps/saga.png
%%DATADIR%%/toolchains/gc_filter_simple.xml
%%DATADIR%%/toolchains/gc_longitudinal_range.xml
%%DATADIR%%/toolchains/gc_tools.xml
+%%DATADIR%%/toolchains/grid_and_polygon_to_table.xml
%%DATADIR%%/toolchains/grid_filter.xml
%%DATADIR%%/toolchains/grid_list_simple_filter.xml
%%DATADIR%%/toolchains/grid_notch_filter.xml
%%DATADIR%%/toolchains/grid_statistics_for_directions.xml
+%%DATADIR%%/toolchains/grid_tools_bulk_no-data_change.xml
%%DATADIR%%/toolchains/gridding.xml
%%DATADIR%%/toolchains/group_files.xml
%%DATADIR%%/toolchains/imagery.xml