aboutsummaryrefslogtreecommitdiff
path: root/math/saga
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-04-01 19:59:45 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-04-01 19:59:45 +0000
commitfd7ef5102563e7fbb1360095516028c7db0d0822 (patch)
tree121aa2c81b18139bb6679735477623db16973b57 /math/saga
parent2f5f8c95888668229b3b626c311e8803b7b0c0f5 (diff)
downloadports-fd7ef5102563e7fbb1360095516028c7db0d0822.tar.gz
ports-fd7ef5102563e7fbb1360095516028c7db0d0822.zip
databases/grass7, math/saga, graphics/qgis and graphics/qgis-ltr: update to latest versions
- math/saga: - Update to 7.6.2 - Use wxWidgets 3.0+ instead of 3.1+ since 3.1 is not a mandatory version and this reduces the number of packages installed when you install saga and qgis/grass (which requires version 3.0). - databases/grass7: - Update to 7.8.2 first version for python3 only - Use ${PY_NUMPY} variable - Readd openmp - Use wxPython40 for python3 - Remove bash dependency. You can use any shell. - Rework the workaround in post-install (for / touch files). Fix the long (random) standing issue with pkg-plist - Alphabetize USES and OPTIONS - Replace XX_configure_on by XX_configure_with as possible - graphics/qgis: - Update to 3.12.1 - Remove patches (applied upstream or fixed in ports: pyqt5 / sip) - graphics/qgis-ltr: - Update to 3.10.4 PR: 241892, 244979 Reported by: rainer hurling (maintainer), lbartoletti (maintainer) Reviewed by: tcberner (mentor), rainer hurling (maintainer) Approved by: tcberner (mentor), rainer hurling (maintainer) Differential Revision: https://reviews.freebsd.org/D24198
Notes
Notes: svn path=/head/; revision=530236
Diffstat (limited to 'math/saga')
-rw-r--r--math/saga/Makefile9
-rw-r--r--math/saga/distinfo6
-rw-r--r--math/saga/files/patch-configure.ac15
-rw-r--r--math/saga/pkg-plist1
4 files changed, 21 insertions, 10 deletions
diff --git a/math/saga/Makefile b/math/saga/Makefile
index 2de9c66fbd64..b6c90a356398 100644
--- a/math/saga/Makefile
+++ b/math/saga/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= saga
-PORTVERSION= 7.5.0
-PORTREVISION= 3
+PORTVERSION= 7.6.2
CATEGORIES= math
MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]\.[[:digit:]]*$//}/SAGA%20-%20${PORTVERSION}
@@ -24,6 +23,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libodbc.so:databases/unixODBC \
libopencv_core.so:graphics/opencv-core \
libopencv_ml.so:graphics/opencv \
+ libpdal_base.so:math/pdal \
libproj.so:graphics/proj \
libsvm.so:science/libsvm \
libtbb.so:devel/tbb \
@@ -33,7 +33,7 @@ RUN_DEPENDS:= swig3.0:devel/swig30
USES= autoreconf compiler:c++11-lib dos2unix gnome \
iconv:wchar_t libtool localbase pkgconfig python
USE_LDCONFIG= yes
-USE_WX= 3.1+
+USE_WX= 3.0+
CONFIGURE_ARGS= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
--enable-python --with-system-svm
@@ -56,7 +56,7 @@ OPENMP_DESC= Enable Multiprocessing (only amd64 and i386)
VIGRA_DESC= Enable 'Vision with Generic Algorithms' Library
OPENMP_CONFIGURE_ENABLE= openmp
-PGSQL_CONFIGURE_WITH= pg
+PGSQL_CONFIGURE_WITH= postgresql
PGSQL_USES= pgsql
VIGRA_BUILD_DEPENDS= ${LOCALBASE}/lib/libvigraimpex.so:graphics/vigra
VIGRA_RUN_DEPENDS= ${LOCALBASE}/lib/libvigraimpex.so:graphics/vigra
@@ -84,6 +84,7 @@ post-extract:
${WRKSRC}/src/tools/io/io_grid_image/Makefile.am \
${WRKSRC}/src/tools/io/io_shapes/Makefile.am \
${WRKSRC}/src/tools/io/io_virtual/Makefile.am \
+ ${WRKSRC}/src/tools/io/io_webservices/Makefile.am \
${WRKSRC}/src/tools/pointcloud/pointcloud_tools/Makefile.am \
${WRKSRC}/src/tools/pointcloud/pointcloud_viewer/Makefile.am \
${WRKSRC}/src/tools/statistics/statistics_kriging/Makefile.am \
diff --git a/math/saga/distinfo b/math/saga/distinfo
index 2def68c15011..a81e0b4b1b75 100644
--- a/math/saga/distinfo
+++ b/math/saga/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1578949425
-SHA256 (saga-7.5.0.tar.gz) = d95c1cba60586916608fd6b262bf75a795a47d6a9b44c2c59a9477015049a168
-SIZE (saga-7.5.0.tar.gz) = 4994149
+TIMESTAMP = 1584819828
+SHA256 (saga-7.6.2.tar.gz) = a02e9f0e605ad7bc1e73513c4bc76d7786e62a4844e10984f1027b559faa4526
+SIZE (saga-7.6.2.tar.gz) = 5019078
diff --git a/math/saga/files/patch-configure.ac b/math/saga/files/patch-configure.ac
index a356794aa747..c77bc0675693 100644
--- a/math/saga/files/patch-configure.ac
+++ b/math/saga/files/patch-configure.ac
@@ -1,4 +1,4 @@
---- configure.ac.orig 2019-04-09 17:14:15 UTC
+--- configure.ac.orig 2020-02-09 11:18:36 UTC
+++ configure.ac
@@ -20,7 +20,7 @@ AC_PROG_LIBTOOL
AC_CHECK_LIB([opencv_core], [cvGetRows], CVFOUND=1,,)
@@ -6,10 +6,10 @@
AC_CHECK_LIB([fftw3],[fftw_execute],FFTWFOUND=1,)
-AC_CHECK_LIB([las], [LAS_GetVersion], LASFOUND=1,,)
+AC_CHECK_LIB([las12], [LAS_GetVersion], LASFOUND=1,,)
+ AC_CHECK_LIB([pdal], [versionString], PDALFOUND=1,,)
AC_CHECK_LIB(hpdf, HPDF_Pages_New, HARUFOUND=1,,)
AC_CHECK_LIB([odbc], [SQLFetch], ODBCFOUND=1,[ODBC \(libodbc\) library not found])
- # PROJ4 has projects.h and old API function:
-@@ -30,8 +30,8 @@ AC_CHECK_HEADER([projects.h],[AC_CHECK_HEADER([proj.h]
+@@ -31,8 +31,8 @@ AC_CHECK_HEADER([projects.h],[AC_CHECK_HEADER([proj.h]
# PROJ6 has dropped projects.h in favour of proj.h and has new API function:
AC_CHECK_HEADER([proj.h],[AC_CHECK_LIB([proj], [proj_info], PROJ6FOUND=1,,)])
AC_CHECK_LIB([vigraimpex], [VIGRA_RGBE_ReadPixels_Raw],VIGRAFOUND=1,)
@@ -20,3 +20,12 @@
PKG_CHECK_MODULES([DXFLIB], [dxflib], [LIBDXFFOUND=1],[LIBDXFFOUND=0])
PKG_CHECK_MODULES([HDF5],[hdf5],LIBHDF5FOUND=1,LIBHDF5FOUND=0)
LIBCURL_CHECK_CONFIG([yes], [7.7.2],,)
+@@ -168,7 +168,7 @@ AC_ARG_ENABLE(openmp,
+ else
+ if test -n "$GOMPFOUND" ; then
+ AC_MSG_RESULT([ Building with OpenMP support using libgomp])
+- GOMPFLAGS="-fopenmp -lgomp"
++ GOMPFLAGS="-fopenmp -lomp"
+ else
+ AC_MSG_RESULT([ libgomp not found, OpenMP support disabled])
+ GOMPFLAGS=""
diff --git a/math/saga/pkg-plist b/math/saga/pkg-plist
index 8af4f2ce4936..1f458f74265f 100644
--- a/math/saga/pkg-plist
+++ b/math/saga/pkg-plist
@@ -75,6 +75,7 @@ lib/saga/libio_shapes_dxf.so
lib/saga/libio_shapes_las.so
lib/saga/libio_table.so
lib/saga/libio_virtual.so
+lib/saga/libio_webservices.so
lib/saga/libpj_georeference.so
lib/saga/libpj_proj4.so
lib/saga/libpointcloud_tools.so