aboutsummaryrefslogtreecommitdiff
path: root/math/sc-im
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2017-01-27 00:16:51 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2017-01-27 00:16:51 +0000
commit6ee27f54b193b03cc790f667d1c2e54e9abccc6f (patch)
treea74d94384f3bb2e4f2768cac25382197a516e286 /math/sc-im
parentb6b1e272dd059afcced7714fd9e7b10086d76b7b (diff)
downloadports-6ee27f54b193b03cc790f667d1c2e54e9abccc6f.tar.gz
ports-6ee27f54b193b03cc790f667d1c2e54e9abccc6f.zip
Notes
Diffstat (limited to 'math/sc-im')
-rw-r--r--math/sc-im/Makefile31
-rw-r--r--math/sc-im/distinfo3
-rw-r--r--math/sc-im/files/patch-Makefile65
-rw-r--r--math/sc-im/files/patch-xls.c11
-rw-r--r--math/sc-im/pkg-descr24
5 files changed, 134 insertions, 0 deletions
diff --git a/math/sc-im/Makefile b/math/sc-im/Makefile
new file mode 100644
index 000000000000..a9d42da52452
--- /dev/null
+++ b/math/sc-im/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= sc-im
+PORTVERSION= 0.4.0
+DISTVERSIONPREFIX= v
+CATEGORIES= math
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Ncurses spreadsheet program for terminal
+
+LICENSE= BSD4CLAUSE
+
+USES= gmake localbase
+
+USE_GITHUB= yes
+GH_ACCOUNT= andmarti1424
+
+USE_GNOME= libxml2
+LIB_DEPENDS= libxlsreader.so:math/libxls \
+ libzip.so:archivers/libzip
+
+WRKSRC_SUBDIR= src
+CFLAGS+= -I${LOCALBASE}/include/libxml2
+MAKE_ENV+= LDLIBS="${LIBS}"
+MAKE_ARGS+= CC="${CC}" prefix="${PREFIX}" MANDIR="${MANPREFIX}/man/man1"
+
+PLIST_FILES= bin/scim \
+ man/man1/scim.1.gz \
+ share/scim/scim_help
+
+.include <bsd.port.mk>
diff --git a/math/sc-im/distinfo b/math/sc-im/distinfo
new file mode 100644
index 000000000000..0d8d0229a4ba
--- /dev/null
+++ b/math/sc-im/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1485473874
+SHA256 (andmarti1424-sc-im-v0.4.0_GH0.tar.gz) = e9a6d0a87d4f9a657bb8b87bdde9141e42c8916fbb6879d07564ffb67302f68a
+SIZE (andmarti1424-sc-im-v0.4.0_GH0.tar.gz) = 700431
diff --git a/math/sc-im/files/patch-Makefile b/math/sc-im/files/patch-Makefile
new file mode 100644
index 000000000000..6d985a5340b1
--- /dev/null
+++ b/math/sc-im/files/patch-Makefile
@@ -0,0 +1,65 @@
+--- Makefile.orig 2016-11-28 12:29:27 UTC
++++ Makefile
+@@ -34,12 +34,12 @@ LIBDIR=$(prefix)/share/doc/$(name)
+ LIBRARY=-DLIBDIR=\"$(LIBDIR)\"
+
+ # For Building SC-IM in LINUX, set LINUX variable below
+-LINUX := -DLINUX
+-#LINUX :=
++#LINUX := -DLINUX
++LINUX :=
+
+ # For Building SC-IM in FREEBSD, set FREEBSD variable below
+-#FREEBSD := -DFREEBSD
+-FREEBSD :=
++FREEBSD := -DFREEBSD
++#FREEBSD :=
+
+ # For Building SC-IM in NETBSD, set NETBSD variable below
+ #NETBSD := -DNETBSD
+@@ -115,15 +115,15 @@ SED := sed
+ # Uncomment below if you want basic XLS import support.
+ # Requires libxlsreader.
+ # Add -lxlsreader in LDLIBS as well.
+-XLS :=
+-#XLS := -DXLS
++#XLS :=
++XLS := -DXLS
+
+ # Uncomment below if you want basic XLSX import support.
+ # Requires libzip-dev and libxml2-dev
+ # Add -lzip -xml2 to LDLIBS as well.
+ # and -I/usr/include/libxml2 or the acording path to the libxml headers, in CFLAGS
+-XLSX :=
+-#XLSX := -DXLSX
++#XLSX :=
++XLSX := -DXLSX
+
+ # Set UNDO variable to enable this feature
+ #UNDO :=
+@@ -134,12 +134,12 @@ UNDO := -DUNDO
+ MAXROWS := 65536
+
+ #CFLAGS := -O2 -Wall -pipe -g
+-CFLAGS := $(LINUX) $(FREEBSD) $(NETBSD) $(MACOSX) -O2 -Wall -pipe -g -I/usr/include/libxml2 $(shell pkg-config --cflags ncursesw)
++CFLAGS := $(LINUX) $(FREEBSD) $(NETBSD) $(MACOSX) $(CFLAGS) #-O2 -Wall -pipe -g -I/usr/include/libxml2 $(shell pkg-config --cflags ncursesw)
+ CFLAGS := $(CFLAGS) $(USECOLORS) $(USELOCALE) $(UNDO) $(SIGVOID) $(DFLT_PAGER)
+ CFLAGS := $(CFLAGS) $(IEEE_MATH) $(RINT) $(REGEX) $(LIBRARY) -DMAXROWS=$(MAXROWS)
+ CFLAGS := $(CFLAGS) $(HELP_PATH) $(SNAME) $(NO_NOTIMEOUT) $(SIMPLE) $(XLS) $(XLSX) $(HISTORY_FILE)
+
+-LDLIBS := -lm $(shell pkg-config --libs ncursesw)
++LDLIBS := -lm $(LDLIBS) -lncursesw -lxlsreader -lzip -lxml2 # $(shell pkg-config --libs ncursesw)
+ #LDLIBS := -lm -lncurses -lxlsreader
+ #LDLIBS := -lm -lncurses -lxlsreader -lzip -lxml2
+
+@@ -157,8 +157,8 @@ install :
+ install $(name) $(DESTDIR)$(prefix)/bin/$(name)
+ install -d $(DESTDIR)$(HELPDIR)
+ install doc $(DESTDIR)$(HELPDIR)/$(name)_help
+- install -d $(DESTDIR)$(prefix)/share/man/man1
+- install -m 644 sc-im.1 $(DESTDIR)$(prefix)/share/man/man1/$(name).1
++ install -d $(DESTDIR)$(MANDIR)
++ install -m 644 sc-im.1 $(DESTDIR)$(MANDIR)/$(name).1
+
+
+ uninstall :
diff --git a/math/sc-im/files/patch-xls.c b/math/sc-im/files/patch-xls.c
new file mode 100644
index 000000000000..599af12ec4c9
--- /dev/null
+++ b/math/sc-im/files/patch-xls.c
@@ -0,0 +1,11 @@
+--- xls.c.orig 2016-11-28 12:29:27 UTC
++++ xls.c
+@@ -60,7 +60,7 @@ int open_xls(char * fname, char * encodi
+ for (c = 0; c <= pWS->rows.lastcol; c++) { // cols
+ xlsCell * cell = xls_cell(pWS, r, c);
+ //if ((! cell) || (cell->isHidden)) continue;
+- if ((! cell) || (cell->ishiden)) continue; // Unfortunately libxls spells this "ishiden"
++ if ((! cell) || (cell->isHidden)) continue; // Unfortunately libxls spells this "ishiden"
+
+ // TODO enable rowspan ?
+ //if (cell->rowspan > 1) continue;
diff --git a/math/sc-im/pkg-descr b/math/sc-im/pkg-descr
new file mode 100644
index 000000000000..74c82b44a49c
--- /dev/null
+++ b/math/sc-im/pkg-descr
@@ -0,0 +1,24 @@
+SC-IM is a spreadsheet program that is based on SC
+
+Some of the features of SC-IM
+ * UNDO / REDO.
+ * 65.536 rows and 702 columns supported. (The number of rows can be expanded
+ to 1.048.576 if wished).
+ * CSV / TAB delimited file import and export.
+ * XLS / XLSX file import.
+ * Key-mappings.
+ * Sort of rows.
+ * Filter of rows.
+ * Cell shifting.
+ * 256 color support - screen colors can be customized by user, even at runtime.
+ * Colorize cells or give them format such as bold or underline.
+ * Wide character support. The following alphabets are supported: English,
+ Spanish, French, Italian, German, Portuguese, Russian, Ukrainian, Greek,
+ Turkish, Czech, Japanese, Chinese.
+ * Implement external functions in the language you prefer and use them in SC-IM
+ * Use SC-IM as a non-interactive calculator, reading its input from a external
+ script.
+ * More movements commands implemented !
+ * Input and Output was completely rewritten
+
+WWW: https://github.com/andmarti1424/sc-im