aboutsummaryrefslogtreecommitdiff
path: root/math/scilab-toolbox-swt
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-07-27 11:03:38 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-07-27 11:03:38 +0000
commit52e8b487f6dc73b0d0baafc955c59e83ab33c41a (patch)
tree167ee4bd8c4cd737246cf4e2c40f36e42042084e /math/scilab-toolbox-swt
parentdbe27c5fd4471209e8b77eecbae08f3a2ad57040 (diff)
downloadports-52e8b487f6dc73b0d0baafc955c59e83ab33c41a.tar.gz
ports-52e8b487f6dc73b0d0baafc955c59e83ab33c41a.zip
- Convert my ports to new options framework
- use CONFLICTS_INSTALL - other minor changes
Notes
Notes: svn path=/head/; revision=301600
Diffstat (limited to 'math/scilab-toolbox-swt')
-rw-r--r--math/scilab-toolbox-swt/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/math/scilab-toolbox-swt/Makefile b/math/scilab-toolbox-swt/Makefile
index b1d38a317854..130406ca4d11 100644
--- a/math/scilab-toolbox-swt/Makefile
+++ b/math/scilab-toolbox-swt/Makefile
@@ -1,6 +1,6 @@
-## New ports collection makefile for: swt
-# Date created: 28 March 2006
-# Whom: Max Brazhnikov makc@issp.ac.ru
+## New ports collection makefile for: swt
+# Date created: 2006-03-28
+# Whom: Max Brazhnikov makc@issp.ac.ru
#
# $FreeBSD$
#
@@ -26,16 +26,19 @@ TOOLBOXDIR= ${PREFIX}/${TOOLBOXDIR_REL}
PLIST_SUB= TOOLBOXDIR=${TOOLBOXDIR_REL}
TOOLBOX_SUBDIRS= demos etc macros
-OPTIONS= SIVP "Enable Image and Video support" off \
- HELP "Build help files (requires scilab with gui support)" on
+OPTIONS_DEFINE= HELP SIVP
+OPTIONS_DEFAULT= HELP
+
+HELP_DESC= Build help files (requires scilab with gui support)
+SIVP_DESC= Enable Image and Video support
.include <bsd.port.options.mk>
-.if defined(WITH_SIVP)
+.if ${PORT_OPTIONS:MSIVP}
RUN_DEPENDS+= ${LOCALBASE}/${CONTRIBDIR}/sivp/loader.sce:${PORTSDIR}/math/scilab-toolbox-sivp
.endif
-.if defined(WITHOUT_HELP)
+.if !${PORT_OPTIONS:MHELP}
SCILAB_ARGS= -nogui
PLIST_SUB+= HELP="@comment "
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-etc__swt.start
@@ -47,7 +50,7 @@ TOOLBOX_SUBDIRS+= jar
.endif
post-patch:
-.if defined(WITHOUT_HELP)
+.if !${PORT_OPTIONS:MHELP}
${REINPLACE_CMD} -e '/tbx_builder_help/d' ${WRKSRC}/builder.sce
.endif
${REINPLACE_CMD} -e "s,SWTDIR+','${TOOLBOXDIR}/demos," \
@@ -56,7 +59,7 @@ post-patch:
pre-build:
${FIND} -d ${WRKSRC} \( -name '*.orig' -or -name '*.bak' \) -delete
-.if !defined(WITHOUT_HELP) && !defined(DISPLAY)
+.if ${PORT_OPTIONS:MHELP} && !defined(DISPLAY)
@if [ -f ${WRKDIR}/.Xvfb.pid ]; then \
${CAT} ${WRKDIR}/.Xvfb.pid | ${XARGS} kill || ${TRUE} ; \
${RM} -f ${WRKDIR}/.Xvfb.pid ; \
@@ -70,7 +73,7 @@ do-build:
${SETENV} ${MAKE_ENV} ${SCILAB_CMD} ${SCILAB_ARGS} -f builder.sce
post-build:
-.if !defined(WITHOUT_HELP) && !defined(DISPLAY)
+.if ${PORT_OPTIONS:MHELP} && !defined(DISPLAY)
@if [ -f ${WRKDIR}/.Xvfb.pid ]; then \
${CAT} ${WRKDIR}/.Xvfb.pid | ${XARGS} kill || ${TRUE} ; \
${RM} -f ${WRKDIR}/.Xvfb.pid ; \