aboutsummaryrefslogtreecommitdiff
path: root/math/scilab-toolbox-swt
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-23 07:52:04 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-23 07:52:04 +0000
commitcf77edae6b22c36ae99624733e9f19aa40d2038a (patch)
tree4adb29e275879c14104c9791aaa569fe74aefee0 /math/scilab-toolbox-swt
parent76b3f6969a07574f48f15fdba1e886c64f2ad265 (diff)
downloadports-cf77edae6b22c36ae99624733e9f19aa40d2038a.tar.gz
ports-cf77edae6b22c36ae99624733e9f19aa40d2038a.zip
- Fix build with gfortran
- Bump PORTREVISION Submitted by: pointyhat via kris Thanks To: maho@ for fix
Notes
Notes: svn path=/head/; revision=183052
Diffstat (limited to 'math/scilab-toolbox-swt')
-rw-r--r--math/scilab-toolbox-swt/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/math/scilab-toolbox-swt/Makefile b/math/scilab-toolbox-swt/Makefile
index 37627d7bcb0e..3a4cd6d1bec8 100644
--- a/math/scilab-toolbox-swt/Makefile
+++ b/math/scilab-toolbox-swt/Makefile
@@ -7,6 +7,7 @@
PORTNAME= swt
PORTVERSION= 0.1.0.r3
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= scwt
@@ -16,9 +17,15 @@ DISTNAME= ${PORTNAME}-0.1.0rc3
MAINTAINER= makc@issp.ac.ru
COMMENT= Scilab 1-D and 2-D Wavelet Toolbox
-BUILD_DEPENDS= scilab:${PORTSDIR}/math/scilab
+BUILD_DEPENDS+= scilab:${PORTSDIR}/math/scilab
-INSTALLS_SHLIB= yes
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+CONFIGURE_ENV+= FC="${FC}" F77="${F77}" FFLAGS="${FFLAGS}"
+
+USE_LDCONFIG= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib/scilab/contrib/swt/lib
HAS_CONFIGURE= yes