aboutsummaryrefslogtreecommitdiff
path: root/math/sdpa
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-01-12 23:42:19 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-01-12 23:42:19 +0000
commit486cf8f7c889a511001ab99894f667d1e3f21e99 (patch)
treef0726600926605d8642c9c9da2b8c6e8629f9da8 /math/sdpa
parent7cddd08996f3e0b24156bf8c152594a046534665 (diff)
downloadports-486cf8f7c889a511001ab99894f667d1e3f21e99.tar.gz
ports-486cf8f7c889a511001ab99894f667d1e3f21e99.zip
Still lapack.h and blas.h are required, though remove dependency
of g2c.h.
Notes
Notes: svn path=/head/; revision=182252
Diffstat (limited to 'math/sdpa')
-rw-r--r--math/sdpa/Makefile10
-rw-r--r--math/sdpa/files/patch-rsdpa_include.h2
2 files changed, 6 insertions, 6 deletions
diff --git a/math/sdpa/Makefile b/math/sdpa/Makefile
index 16f8f3daa8ef..c28566e93737 100644
--- a/math/sdpa/Makefile
+++ b/math/sdpa/Makefile
@@ -34,11 +34,11 @@ OLDVERSION= 6.2.0
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-#Atlas is always required as lapack.h and blas.h is required.
-#no blaswarp.h at the moment.
-LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
-
-WITH_ATLAS= yes
+#for f2c.h
+BUILD_DEPENDS= ${LOCALBASE}/lib/libf2c.a:${PORTSDIR}/lang/f2c
+#.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
+WITH_ATLAS= yes
+#.endif
.if defined(WITH_ATLAS)
BLAS= -lcblas -lf77blas -latlas
LAPACK= -lalapack
diff --git a/math/sdpa/files/patch-rsdpa_include.h b/math/sdpa/files/patch-rsdpa_include.h
index e27d3efbe5a4..b7eb5cbb2753 100644
--- a/math/sdpa/files/patch-rsdpa_include.h
+++ b/math/sdpa/files/patch-rsdpa_include.h
@@ -5,7 +5,7 @@
extern "C" {
-#include <f2c.h>
-+#include <g2c.h>
++#include <f2c.h>
#if NON_ATLAS_SDPA
#include <blaswrap.h>
#endif