aboutsummaryrefslogtreecommitdiff
path: root/math/secp256k1
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-06-28 15:51:28 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-06-28 15:51:28 +0000
commit98b5a3ec78b085a327671da92778a9da82b5cbcb (patch)
tree253d4f8f249d2def0abbebb1356e668923b09653 /math/secp256k1
parentd2952870588af9b693af822d021485999801c863 (diff)
downloadports-98b5a3ec78b085a327671da92778a9da82b5cbcb.tar.gz
ports-98b5a3ec78b085a327671da92778a9da82b5cbcb.zip
- Switch to options helpers
- Switch to new test framework Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=505289
Diffstat (limited to 'math/secp256k1')
-rw-r--r--math/secp256k1/Makefile17
1 files changed, 4 insertions, 13 deletions
diff --git a/math/secp256k1/Makefile b/math/secp256k1/Makefile
index c839e66d1555..169de86c27e1 100644
--- a/math/secp256k1/Makefile
+++ b/math/secp256k1/Makefile
@@ -22,31 +22,22 @@ OPTIONS_DEFINE= GMP JAVA
OPTIONS_DEFAULT=GMP JAVA
GMP_DESC= Use GMP bignum implementation
+GMP_USES= localbase:ldflags
GMP_LIB_DEPENDS=libgmp.so:math/gmp
GMP_CONFIGURE_ON=--with-bignum=gmp
GMP_CONFIGURE_OFF=--with-bignum=no
JAVA_DESC= Build JNI bindings
JAVA_CONFIGURE_ENABLE=jni
+JAVA_USE= JAVA=yes
+JAVA_CONFIGURE_ENV=JAVA_HOME="${JAVA_HOME}"
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-experimental --enable-module-ecdh \
--enable-endomorphism --enable-module-recovery
INSTALL_TARGET= install-strip
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGMP}
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-.endif
-
-.if ${PORT_OPTIONS:MJAVA}
-USE_JAVA= yes
-CONFIGURE_ENV+= JAVA_HOME="${JAVA_HOME}"
-.endif
-
-check regression-test test: build
+do-test:
cd ${WRKSRC} && ./tests
.include <bsd.port.mk>