aboutsummaryrefslogtreecommitdiff
path: root/math/slatec
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-07-13 13:08:15 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-07-13 13:08:15 +0000
commitff041acd7e03d01f7ce65eb113b148391cd8acc2 (patch)
treebcf4d18fe69e3c02b9d4ceff021099df22118aa3 /math/slatec
parentf1bd02d77bd8b8fbf47b87dfe794db3ae7ead77e (diff)
downloadports-ff041acd7e03d01f7ce65eb113b148391cd8acc2.tar.gz
ports-ff041acd7e03d01f7ce65eb113b148391cd8acc2.zip
- Convert to new options framework
PR: ports/169821 Submitted by: Anton Shterenlikht <mexas@bristol.ac.uk> (maintainer, new address)
Notes
Notes: svn path=/head/; revision=300858
Diffstat (limited to 'math/slatec')
-rw-r--r--math/slatec/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/math/slatec/Makefile b/math/slatec/Makefile
index b5cb3806e27f..4f548c449043 100644
--- a/math/slatec/Makefile
+++ b/math/slatec/Makefile
@@ -26,6 +26,7 @@ WRKSRC= ${WRKDIR}/src
SHLIB_MAJOR= 1
PLIST_FILES= lib/libslatec.a lib/libslatec.so lib/libslatec.so.${SHLIB_MAJOR}
+PORTDOCS= guide toc
LDFLAGS+= ${FFLAGS}
LDADD ?= -lgfortran -lm
@@ -33,16 +34,16 @@ SRCCONF= ${NONEXISTENT}
MAKE_ENV+= LDADD="${LDADD}" SHLIB_MAJOR="${SHLIB_MAJOR}" \
SRCCONF="${SRCCONF}"
-OPTIONS= PROFILE "Build a profiling library" Off
+OPTIONS_DEFINE= DOCS PROFILE
.include <bsd.port.options.mk>
-.if defined(WITH_PROFILE)
+.if ${PORT_OPTIONS:MPROFILE}
.if defined(NOPROFILE) || defined(NO_PROFILE) || defined(WITHOUT_PROFILE)
-IGNORE = you have defined WITH_PROFILE, but have also defined\
+IGNORE= you have selected PROFILE option, but have also defined\
WITHOUT_PROFILE, NOPROFILE, or NO_PROFILE
.elif !exists(/usr/lib/libc_p.a)
-IGNORE = you have chosen WITH_PROFILE, but have not installed the\
+IGNORE= you have chosen WITH_PROFILE, but have not installed the\
base system profiling libraries
.endif
PLIST_FILES+= lib/libslatec_p.a
@@ -72,12 +73,10 @@ test-${l}: build
.endfor
-.if !defined(NOPORTDOCS)
-PORTDOCS= guide toc
-
post-install:
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@cd ${_DISTDIR}; ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-
.endif
+
.include <bsd.port.mk>