aboutsummaryrefslogtreecommitdiff
path: root/math/solitaire/Makefile
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-02-15 14:44:36 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-02-15 14:44:36 +0000
commit4748962959eb06a89171d944f5a62829fbac8900 (patch)
treec976e5f961c05dff0d3020053d09732cc88a8ef3 /math/solitaire/Makefile
parent045b1fbdf5e75baa86054ee84889989c05d99155 (diff)
downloadports-4748962959eb06a89171d944f5a62829fbac8900.tar.gz
ports-4748962959eb06a89171d944f5a62829fbac8900.zip
Notes
Diffstat (limited to 'math/solitaire/Makefile')
-rw-r--r--math/solitaire/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/math/solitaire/Makefile b/math/solitaire/Makefile
index fc0b8eb5bdea..5e6367689311 100644
--- a/math/solitaire/Makefile
+++ b/math/solitaire/Makefile
@@ -3,27 +3,30 @@
PORTNAME= solitaire
PORTVERSION= 19980817
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= dd
DISTFILES= sol.pl sol-test.txt
MAINTAINER= ports@FreeBSD.org
-COMMENT= The reference implementation of the Solitaire encryption algorithm
+COMMENT= Reference implementation of the Solitaire encryption algorithm
+
+USES= perl5 shebangfix
+SHEBANG_FILES= sol.pl
NO_BUILD= yes
NO_WRKSUBDIR= yes
STRIP=
-NO_STAGE= yes
do-extract:
@${MKDIR} ${WRKDIR}
@${CP} -r ${DISTDIR}/sol.pl ${DISTDIR}/sol-test.txt ${WRKDIR}
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/sol.pl ${PREFIX}/bin/solitaire
- @${MKDIR} ${PREFIX}/share/doc/solitaire
- @${INSTALL_DATA} ${WRKSRC}/sol.pl ${WRKSRC}/sol-test.txt \
- ${PREFIX}/share/doc/solitaire
+ ${INSTALL_PROGRAM} ${WRKSRC}/sol.pl ${STAGEDIR}${PREFIX}/bin/solitaire
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/solitaire
+ ${INSTALL_DATA} ${WRKSRC}/sol.pl ${WRKSRC}/sol-test.txt \
+ ${STAGEDIR}${PREFIX}/share/doc/solitaire
.include <bsd.port.mk>