aboutsummaryrefslogtreecommitdiff
path: root/math/sound-of-sorting
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2016-02-22 08:12:44 +0000
committerStefan Eßer <se@FreeBSD.org>2016-02-22 08:12:44 +0000
commit262eb57c5d00820484bb63fbd15d052a7b58c5cd (patch)
treefbee60f867e02a2db6acd544c0ed94853afde1ed /math/sound-of-sorting
parentb1c24e571b577108d103f97008b1fdd106af3862 (diff)
downloadports-262eb57c5d00820484bb63fbd15d052a7b58c5cd.tar.gz
ports-262eb57c5d00820484bb63fbd15d052a7b58c5cd.zip
Notes
Diffstat (limited to 'math/sound-of-sorting')
-rw-r--r--math/sound-of-sorting/Makefile33
-rw-r--r--math/sound-of-sorting/distinfo2
-rw-r--r--math/sound-of-sorting/pkg-descr7
3 files changed, 42 insertions, 0 deletions
diff --git a/math/sound-of-sorting/Makefile b/math/sound-of-sorting/Makefile
new file mode 100644
index 000000000000..fbf94f4f0177
--- /dev/null
+++ b/math/sound-of-sorting/Makefile
@@ -0,0 +1,33 @@
+# Created by: Stefan Esser <se@StefanEsser.FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= sound-of-sorting
+PORTVERSION= 0.6.5
+CATEGORIES= math
+
+MAINTAINER= se@FreeBSD.org
+COMMENT= Visualization and "Audibilization" of Sorting Algorithms
+
+LICENSE= GPLv3
+
+GNU_CONFIGURE= yes
+USE_SDL= sdl
+USE_WX= 2.8+
+WX_CONF_ARGS= relative
+
+OPTIONS_DEFINE= DOCS
+
+USE_GITHUB= yes
+GH_ACCOUNT= bingmann
+GH_PROJECT= sound-of-sorting
+GH_TAGNAME= ${PORTNAME}-${PORTVERSION}
+
+PLIST_FILES= bin/sound-of-sorting
+PORTDOCS= README
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/sound-of-sorting ${STAGEDIR}${PREFIX}/bin/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/sound-of-sorting
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${PREFIX}/share/doc/sound-of-sorting/README
+
+.include <bsd.port.mk>
diff --git a/math/sound-of-sorting/distinfo b/math/sound-of-sorting/distinfo
new file mode 100644
index 000000000000..f373f7ce89d9
--- /dev/null
+++ b/math/sound-of-sorting/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bingmann-sound-of-sorting-0.6.5-sound-of-sorting-0.6.5_GH0.tar.gz) = cb9c4e94842a015c7d144710dbee6b6a104e35deb0042657fac780e22b5c4494
+SIZE (bingmann-sound-of-sorting-0.6.5-sound-of-sorting-0.6.5_GH0.tar.gz) = 174437
diff --git a/math/sound-of-sorting/pkg-descr b/math/sound-of-sorting/pkg-descr
new file mode 100644
index 000000000000..82f9fcea8ae9
--- /dev/null
+++ b/math/sound-of-sorting/pkg-descr
@@ -0,0 +1,7 @@
+This program demonstrates the working principles of some 20 sorting
+algorithms and is very easy to use. Select the algorithm, the speed
+of the visualisation and whether you want to get sound output (that
+reflects the values being moved and is characteristic for each kind
+of algorithm).
+
+WWW: http://panthema.net/2013/sound-of-sorting/