aboutsummaryrefslogtreecommitdiff
path: root/math/speedcrunch
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-03-16 16:03:11 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-03-16 16:03:11 +0000
commitabc623e206724ec179a680f29bc4e3ffa0a638f9 (patch)
tree6823066f0ff44915be07f2858b40de8cb152ee5b /math/speedcrunch
parentc5dc55471e3b30a28ebf362204ee94a73081ad11 (diff)
downloadports-abc623e206724ec179a680f29bc4e3ffa0a638f9.tar.gz
ports-abc623e206724ec179a680f29bc4e3ffa0a638f9.zip
- Reorder Makefile knobs to what is normally expected in our ports, and
switch from setting more low-level CMAKE_SOURCE_PATH to WRKSRC_SUBDIR - Current port version is 0.12.0 while upstream lists it as 0.12; while they're equal per `pkg version -t', leave an XXX note to make both of them consistent and report correct version in the About dialog window - Take the port under my wing for the time being
Notes
Notes: svn path=/head/; revision=495901
Diffstat (limited to 'math/speedcrunch')
-rw-r--r--math/speedcrunch/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/math/speedcrunch/Makefile b/math/speedcrunch/Makefile
index 6a43d66f9c18..d53f363e9ef6 100644
--- a/math/speedcrunch/Makefile
+++ b/math/speedcrunch/Makefile
@@ -2,31 +2,31 @@
# $FreeBSD$
PORTNAME= speedcrunch
-PORTVERSION= 0.12.0
+PORTVERSION= 0.12.0 # XXX: should really be 0.12, change upon next update
DISTVERSIONSUFFIX= -${BB_COMMIT}
PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= https://bitbucket.org/${BB_ACCOUNT}/${BB_PROJECT}/get/${BB_COMMIT}.tar.gz?dummy=/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= Keyboard-oriented desktop scientific calculator
LICENSE= GPLv2+
-USES= cmake compiler:c++11-lang qt:5
-
BB_ACCOUNT= heldercorreia
BB_PROJECT= ${PORTNAME}
BB_COMMIT= c0fc9c68d292
-WRKSRC= ${WRKDIR}/${BB_ACCOUNT}-${BB_PROJECT}-${BB_COMMIT}
-CMAKE_SOURCE_PATH= ${WRKSRC}/src
+USES= cmake compiler:c++11-lang qt:5
USE_QT= buildtools_build qmake_build core gui help sql widgets
USE_XORG= x11
+WRKSRC= ${WRKDIR}/${BB_ACCOUNT}-${BB_PROJECT}-${BB_COMMIT}
+WRKSRC_SUBDIR= src
+
post-patch:
@${REINPLACE_CMD} -e 's|-W[-_[:alnum:]]*|| ; s|metainfo|appdata| \
- ; s|master|${PORTVERSION}-git-${BB_COMMIT}|' \
+ ; s|master|${PORTVERSION:R}-git-${BB_COMMIT}|' \
${CMAKE_SOURCE_PATH}/CMakeLists.txt
.include <bsd.port.mk>